11

I have a Dell Inspirion and the power supply port appears to be damaged.

Basically when I plug it in I get a nice popup telling me that it couldn't detect that its a Dell power supply so it won't charge the battery and underclocks the system. It still works for other purposes (that is, giving power).

I thought it was the actual power supply cable so I bought a new one, that worked for a while, provided I inserted it at JUST THE RIGHT angle. But now that's not working anymore, so I assume its the part which connects to the computer.

The battery charging I can live without, the underclocking I can't. I'd like a way around this issue. Things I've tried:

  1. Updating the BIOS
  2. Replacing the power supply cable
  3. Inserting it at different angles
  4. Turning it off and on again
  5. Swearing at it
  6. Twisting it while inserting it

So, is there a workaround somehow? I'd like to avoid taking out my soldering kit and risking permanently damaging expensive equipment if that's allright. I'm hoping for a software solution.

Added: The exact model is a Del Inspirion N5010

  • Interesting to learn the theory behind why its causing the issue, but it doesn't help my issue. – Haedrian Jun 29 '12 at 9:37
  • 1
    I have Dell Inspiron N5010 and I had exactly the same problem. I took it to the service and got it replaced for around 20€. Then I replaced cooler (20€). Then I replaced one chip for screen (50€). Screen was all white. Then my video card died because of overheat. That one he saved (50€), how I don't know. And now it can't recognize battery and won't charge it. Guess what laptop I am not going to buy next. – Ljubomir Đokić Aug 7 '15 at 10:57
  • 1
    and #5 DIDN'T work?! That's a first – Blaine Jul 16 '17 at 13:19
10

If you're ready for a hardcore solution, you can unsolder the ID chip from the AC adapter and solder it to the laptop's motherboard or even create a fake ID chip.

An ideal solution would be to patch the BIOS, but I've found only this discussion, nobody did it (yet?)

Can something be done on the software side?

Yes! At least, we can overcome underclocking. Battery won't load.

Linux:

Add processor.ignore_ppc=1 to GRUB_CMDLINE_LINUX in /etc/default/grub, then run update-grub. Reboot.

Windows:

This paper describes Windows XP performance control policies and mentions this:

NOTE: All policies will always respect the highest available performance state currently available as reported in the _PPC method by system firmware, when using the ACPI 2.0 interface.

So, no native support. But there are third-party tools. I personally had success with RMClock, other people in this thread suggest using ThrottleStop instead.

| improve this answer | |
3

This solved my issue in two laptops, I searched and never came across this so I wanted to post it for someone else. These dell laptops were purchased refurbished with 3rd party chargers, batteries are dell.

8/17/2018 RE: Problem with laptops (E5430)

REINSTALL BATTERY DRIVER - Shut down the laptop - Unplug the AC Adapter from laptop - Remove the battery - Reconnect the AC Adapter to the laptop - Power on - Go the Start and type in Device Manager (search program and files) then Enter - Under Batteries, uninstall Microsoft AC Adapter and Microsoft ACPI- Compliant Control Method Battery (both) - Please note that this will auto-install for you again - Shut down laptop - Remove the AC Adapter from laptop - Insert the Battery and reconnect the AC Adapter - Power on the computer - You should now see the message, Plugged in, Charging

| improve this answer | |
2

FWIW: I "solved" it by disabling the SpeedStep Technology part in the BIOS.

Although the description there implies that this will then run the CPU at full throttle 100% of the time this not the case in reality. TaskManager shows the frequency to go up and down according to the load.

This does not fix the actual "PSU not recognized"-issue, but at least the machine isn't stuck at 1.18GHz anymore because of that.

| improve this answer | |
  • It does work well with Dell Precision M4800 Windows7. Tested it on 2 laptops. Thank you. – user.dz Jul 5 '19 at 11:03
1

Sounds like it's the DC jack. Please note however that not all laptops require soldering to replace the DC jack. Some of them are removable components. You haven't told us which exact model Inspiron you have.

| improve this answer | |
  • Its a Dell Inspirion N5010, I updated the original question. – Haedrian Jun 28 '12 at 20:04
  • 1
    From what I can tell by searching around, this is a model that does need soldering. Unfortunately, software cannot solve this. It's possible a BIOS hack could, but that would be a lot of work for something that's going to get worse anyway. Eventually no electricity will get to it at all. Your only recourse is soldering a new DC jack onto the board, or buying a replacement board. It's also very hard to say, given that the laptop is not in front of me. – jlacroix82 Jun 28 '12 at 20:14
  • Well that sucks. I guess I'll back up everything very deeply and replace it. I'm not really the kind of person to open up a laptop and play around with the insides unless its really dead. THe connector does feel loose and it feels like its not entering correctly (I can see the metal a bit) - does that tell you anything? – Haedrian Jun 28 '12 at 20:23
  • Sounds typical. I get this problem with my repair business every now and then. If you aren't comfortable opening it up, you'll have to replace it. Otherwise if it at all lasts until it dies all the way, use it until it breaks and attempt to repair yourself if you want. Keep your data backed up. – jlacroix82 Jun 28 '12 at 20:45
1

Okay, this is a well known issue. For whatever reason, on the power pin, Dell included a signal to tell the laptop what kind of power supply is connected. This does not always work right. In fact, there are MANY reports of this failing. There is usually a setting in the BIOS to fix this - you will have to boot to the BIOS and look around. The setting is usually about detecting power supply and to inactivate this feature.

Note: Seems from searching, some versions of the BIOS don't have the ability to shut off AC Adapter detection. Just have to try and search yours.

| improve this answer | |
1

My solution is ridiculously simple. But it works. First unplug the power cable from both ends. Also unplug the adapter. Then plug in everything and power up the computer. Then, when the computer is on, unplug the adapter, wait a few seconds and plug it back in. That's all. Don't know why, but it works.

| improve this answer | |
  • removing and then adding works – Ashad Nasim May 6 at 7:33
0

For what it is worth, I have an xps 1502x with a temperamental 130 watt power supply. It would work sometimes and then not be recognized and charge the battery, only power the laptop. Sometimes reinserting or "cleaning" the connector would work. Saw another reply on another question/comment mentioning center pin wire breaking internally and requiring either new adapter or resoldering the middle pin wire. I tired the resolder middle pin option and it now works again. Cheaper than a new adapter. Hardest step was cutting open the wires at the connector pin.

| improve this answer | |
0

I was getting this error message on my 11" Dell Insipiron. Solved the problem when I noticed that inside the DC socket (on the laptop) is a central locating pin which need to be straightened. It was hard to identify as the pin protrudes only half the distance of the socket. I fixed it by re-straightening it with a dressmakers pin, a magnifying glass and some additional illumination helps. The problem became evident because I could no longer insert the DC jack (from the charger) fully into the laptops socket, it would power up the laptop, but not allow the battery to be charged.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.