I installed Startup Manager in Ubuntu 9.04 (Jaunty) to try to hide the boot text that is displayed on screen. I've played with numerous combinations of options as described in this guide. Particularly these:

  • Show bootloader menu. When selected the bootloader menu displays available options such as kernels, recovery modes, memtest86+, and other operating systems, if installed. If this option is not selected, no bootloader menu will be displayed during boot. The default or saved OS selection will be used.

  • Show boot splash. Enables the splash screen viewed during the boot process.

  • Show text during boot.

  • Manage bootloader themes. Add or remove an installed bootloader theme.

  • Usplash theme.

alt text

However, nothing makes the boot messages go away, starting with "Reading files need for boot" and then listing a whole bunch of information such as setting up the firewall etc, which drivers are loaded etc.

Is there any other approach I could use?

  • Have yo uchecked dmesg output to see if the system tried unsuccessfuly to initialize the graphical boot?
    – user4358
    Sep 20, 2009 at 19:59
  • nagul: no. i assumed that if graphical boot failed, then gnome would fail too. but your're right - they're not neces sarily related - i will try to figure out how to set this option. thanks.
    – lipton
    Sep 20, 2009 at 20:16

3 Answers 3


To disable boot messages, you need to pass the quiet option to the kernel at boot time. This is usually done by editing the grub configuration file at /boot/grub/menu.lst.

Detailed descriptions on exactly how to go about this on Ubuntu can be found in the Ubuntu wiki.

Note that you are NOT supposed to uncomment the # kopt=<options go here> line, as all the commented lines in the menu.lst file is parsed by update-grub, which modifies the kernel entries further down in the file accordingly.


To also hide kernel messages (when booting in text mode (e.g. with nomodeset)), I found out that one has to pass loglevel=3 to the kernel.

This is very useful when systemd stops at a crypto prompt "Please enter passphrase for disk", and it used to be spammed with kernel messages about audio devices and other stuff.


Alternatively, you could run Karmic, it has one built in and it's pretty much a Release Candidate now.


  • Alpha 6 != Release Candidate. Doubly true for the 64-bit builds. I'm using the karmic alpha right now, and it's nice, but I wouldn't recommend it as a solution to any specific problem.
    – regan
    Sep 20, 2009 at 22:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .