I installed a new system last week. I've some issues with it.

The system consists of a:

  • Gigabyte GA-Z77X-D3H with F9 BIOS (latest)
  • Intel Core i5 3570K proccesor
  • Sapphire Radeon HD7850
  • 2x 8GB Corsair 1600MHz memory
  • OCZ Vertex 2 120G SSD

Connected peripherals :

  • 2 Samsung 940BF (1 via DVI on GFX card, 1 via an Displayport to DVI adapter)
  • 1 Dell U2312HM monitor (displayport)
  • Dell USB Hub (monitor)
  • Wired mouse, wireless keyboard (logitech)
  • Logitch G25 wheel
  • Canon MP800 printer

Okay, my issues are the following: if I plug in 1 or more monitor at DisplayPort during boot, most of the time it won't boot properly. I get an empty message screen of UEFI: only the header GIGABYTE DUEL BIOS appears. The system reboots itself, turns on for a few seconds (no video) and then reboots again. Now it starts all over again. This repeats until I remove all displayport monitors. Windows boots, and I can use them when I replug them.

The graphics card has been running fine for a few weeks on an older system (intel Q6600).

Another issue is; if I plug in my G25 steering wheel, the UEFI BIOS is inaccessible. It either gives the same empty UEFI screen, or the BIOS screen is rendering but crashes half way (so pieces of text and graphics are missing, and it has crashed). If I remove the G25, all is fine.

To verify the graphics card is OK and the motherboard is causing these issues, I tried an NVIDIA 8800GT graphics card. This hasn't got Displayport, but it also cannot boot the BIOS with the G25 wheel plugged in.

The PC also refuses to go into or out of standby. It just hangs when going into standby, and in other occasions (when it does succesfully do so) get out of standby.

Power supply is OCZ StealthXStream 600W. Proccesor is 25 - 30C idle, ~55C stressed (Scythe Mugen 2).

I am really puzzled what can be done to resolve this. I am not really waiting for an RMA request (otherwise I will return the MB for another type), because it will likely mean I have to wait very long before I get a replacement. Anyone else with a similar experience on this board/chipset or can help me troubleshoot this?

  • I had similar problem, and with the exact same cause. In my case motherboard is Asus P8Z77-V LX, and with the bad cable it won't power on at all. Could we update this question for the sake of future Google searches to 1) start a list of known problematic hardware 2) remove not so relevant specifics? – cuu508 Jan 4 '13 at 13:24

I had exactly the same problem and figured out it is was the cable not the motherboard! The spec for Displayport cables directs that pin 20 (power) should not be connected. However, many (cheaper) cables don't adhere to this. Some devices (esp Dell monitors and Gigabyte motherboards) fail completely in this situation - I assume other devices are somehow better configured to handle unexpected power being received, though it's hard to blame Gigabyte.

My solution was to break pin 20 in the cable connector (it's the bottom right pin looking in to the cable, with the 'U'-shaped grooves pointing downwards). A branded cable would also work. Maybe Gigabyte will also eventually update their BIOS to handle this (as of F14 it is not working), though it could also be a hardware problem that can never be fixed in BIOS. Also the engineers may never reproduce the issue in the lab if they are using 'proper' cables...

  • I have seen this numerous times myself, and it took us forever to figure it out initially. This man is absolutely right. – Shinrai Nov 20 '12 at 22:23
  • I've heard more responses from people (on other review sites) that this helped their problem. For me it's too late, I went to an Asus board which worked with the same hardware setup first go. I've given you the answer 'reward' for this question, anyway. ;) – Hans Dec 9 '12 at 18:26

I've decided to RMA the board (not as a DOA, but trading it for another brand). I have searched a bit more and it appears some Z77 bios, in particular Gigabyte, contain a lot of bugs. Fixes are released every month or so, but progress is slowly and it's unlikely the next release will fix everything or without introducing new bugs.

So for people experiencing similar issues, try updating your BIOS. By the time you read this, it may well be fixed. I'm not going to wait on this, if I can't normally boot my PC or enter my BIOS without unplugging devices, it's ridiculous.

I'm going back to Asus, I have experience on 2 other systems that work just fine. Too bad, this Gigabyte board has a very complete feature set. The Asus equivalent sets me back another 30euro's($), but oh well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.