I recently got a Western Digital MyBook external hard drive to enable Time Machine. It has its software installed on a "virtual CD" called "WD SmartWare" which shows up on the desktop any time the drive is plugged in. Since I will use this virtual drive only very rarely, how can I hide it from the desktop, while allowing other CDs to show up?


10 Answers 10


WD has posted the steps to remove the Smartware and its VCD, Mac or Windows...

STEP 1: Firmware Update: Release 2.003 (3/4/10)

Before running the Virtual CD Manager, you must first update the firmware on your hard drive.

  1. Disconnect all other external drives from the computer except for the My Book or My Passport drive you want to update.

  2. Ensure that the My Book or My Passport drive is connected to a USB port on your computer.

  3. Download the Firmware Updater for Windows.

  4. Unzip the file and double click to open the Firmware Updater.

  5. Click Continue to update the firmware.

  6. Click Accept the End User's License Agreement (EULA). The updater will scan the drive which may take a few minutes.

  7. Verify the attached drive's serial number located on the back of the drive.

  8. Click Update Firmware.

  9. Once the updater is finished, click Exit.

  10. Turn off the drive - For My Passport, disconnect the USB cable. For My Book disconnect both USB and power cables.

  11. Wait 10 seconds. Reconnect the USB/power cables.

STEP 2: Download and run the VCD Manager

  1. Download VCD Manager for Windows.(WDSmartWareVirtualCDManagerforWindows-v1.0.7.4.zip) to your desktop.

  2. Unzip the utility (Extract the file using an extraction utility.)

  3. Double click WDSmartWareVirtualCDManagerforWindows-v1.0.7.4.exe.

  4. Click Continue to disable the VCD.

  5. Once the utility has found your drive, click Configure Drive and then click Exit.

  6. Turn off the drive - For My Passport, disconnect the USB cable. For My Book disconnect both USB and power cables.

  7. Wait 10 seconds. Reconnect the USB/power cables that have been disconnected in the previous step.

  8. Verify that the VCD no longer appears.

  • 2
    Successfully updated firmware tonight, and everything looks good so far. Dec 4, 2009 at 1:41
  • 3
    Much better to not have the annoying software launching, but does anyone know of good instructions to eliminate the partition?
    – jnewman
    Jan 4, 2011 at 4:54
  • 3
    This doesn't really remove the partition, you know.
    – kinokijuf
    Nov 15, 2011 at 17:31
  • Couldn't you just remove it with a partition manager like gparted or whatever there is for osx?
    – Rob
    Nov 15, 2011 at 18:33
  • 1
    Why does this have 32 upvotes? This doesn't answer the question at all. Jan 23, 2012 at 18:39

On Mac OS X you can unmount the SmartWare partition for good by editing /etc/fstab and adding a line:

UUID=your_smartware_partitions_uuid_here none hfs rw,noauto 0 0

You'll get the UUID by typing diskutil info /Volumes/WD\ SmartWare within Terminal.app.

A one liner for this:

sudo sh -c "echo UUID=`diskutil info /Volumes/WD\ SmartWare/ | grep 'UUID' | awk '{print $NF}'` none hfs rw,noauto 0 0 >> /etc/fstab"
  • Nice! Just tried this and it worked great! Thank you! Note to others who might be thinking about trying this: /etc/fstab did not exist previously on my system; the above one-liner (or whatever other method you choose) creates it, and it is heeded upon next connection of the device.
    – lindes
    Jan 27, 2011 at 19:37
  • Hmm, it's perhaps worth noting, too, that removing /etc/fstab doesn't make it come back. Removing the line from /etc/fstab does, however.
    – lindes
    Jan 27, 2011 at 19:51
  • Neat idea, but you have do do this on each computer you use it on. Jan 23, 2012 at 18:39

The instructions at this link will allow you to disable the VCD firmware: http://www.wdc.com/wdproducts/updates/?family=wdsmartwareutilities


Gparted is a great utility, but it will not delete the VCD partition. That was the first thing I tried. I had to install their crapware to disable it.


For Mac OS X I followed the instructions already posted above: http://www.wdc.com/wdproducts/updates/?family=wdsmartwareutilitiesmac

but VCD didn't work until I changed the security preferences, which I had to do with the smartware to get rid of the password. Then after VCD worked, the My Book was still read only, so I used the smartware which was still installed to erase everything already on the drive, and then it finally worked like an external hard drive is supposed to and was read and writable (and then I deleted the smartware software I had installed on my computer)

...this hard drive was a pain in the neck

  • 1
    Did this actually remove the hidden partition? (We have ~20 of these at work, came with Dell PCs, so this partition is wasting a good deal of space for us.) :(
    – jnewman
    Jan 4, 2011 at 4:59

I just plugged it in to one of my system. Then I booted that system up to an Xp install CD and then when given the option from the CD as to what hard-drive I wanted to install to I chose the MyBook and deleted the partition and then formatted it using the Install cd. Once tha formatting was done, I then canceled the CD boot and restarted my system. Now I have a clean MyBook with nothing on it at all, just like the darn thing is supposed to be.

Also this works for any USB.

  • Disk Utility only shows one partition. I suppose I could redo it manually to make certain. Sep 21, 2009 at 2:47

I wanted remove the VCD partition, instead of hiding it. This problem frustrated me to no end, but I was finally able to completely remove the VCD from two WD SmartBooks.

There were two steps that actually seem to have done something.

First, on Windows, I updated the BIOS as @Gnoupi suggests (I'm not convinced I needed to do this, but I won't undo it).

Second, on Linux, I ran palimpsest (a disk management utility w/ a GUI) removed all visible partitions and chose Format drive -> Master Boot Record -> BSD. I then chose Format drive->don't partition.

I am now able to access all of the 999gb capacity and do what I want with it.


Two solutions to actually get rid of the VDC (not just hide it):

  1. Return it to the store and buy a different brand.

  2. Tear open the casing, pull out the hard drive, and put it into a generic 3.5" SATA enclosure.

  • 2
    It is not possible to pll out the HDD in recent versions. The USB controller is integrated on the drive.
    – kinokijuf
    Jan 23, 2012 at 20:48

Included on the "VCD" is the software required to enable and disable it. It's called "Virtual CD Manager.app", on MacOS (I presume something similar exists when mounted under Windows?)

You have to copy it to your hard drive to run it (otherwise, it gives you an error message saying as much), and once you've done that, you just run it and follow the prompts. Each time you go through the process, it will alternate between being visible and being hidden.

Note: This software is the same software that you can download as mentioned in other answers... In this answer, I'm just pointing out that a version of it (though presumably it may not be the latest version, and therefore you may want to download it) exists on the "virtual CD" already, which you can copy and run.

  • Not on all versions, apparently. My mom's drive doesn't have VCD manager on the VCD itself. Even after downloading the VDC manager separately, it still won't work because the drive has a password. I know the password but I can't figure out how to remove it. WD has awful, awful customer service. Last WD drive I ever buy. Jan 23, 2012 at 18:42

All answers are WRONG.

Here is the way (you must download sg3_utils package)

dev=$(sg_scan |grep "My Book"|cut -d' ' -f 1)
cfg=$(sg_raw -r 12 $dev 1a 00 20 00 0C 00 02 2>&1|cut -d " " -f 7-19)
disvcd="$(echo $cfg|cut -d " " -f 2-9) 00 $(echo $cfg|cut -d " " -f 11-13)"
echo $disvcd |xxd -r -p|sg_raw -s 12 $dev 15 11 00 00 0C 00 01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .