Until a few days ago I hadn't had any problems, but now I can't use file and printer sharing in Windows 7 but everyone else on the network can.

It is possible I installed some program that made a change or disabled a windows service! (Like: proxifier, ...)


  • I can ping everyone on the network.

  • Everyone can ping me.

  • I can't see their computers in Windows 7 "Networks", so I can't use file and printer sharing.

  • Everyone can see my computer in windows 7 "Networks", and also can use my file and printer sharing.

  • With a LAN messenger program, we(I & everyone) can text chat, video chat and transfer files.

How do I configure my computer so as to see other computers on the network and use Windows 7 file and printer sharing?

these screenshos, maybe help:

And one funny thing: I cant see my computer by IP i cant see my computer by IP

  • Can you access other by using their IP? try typing \\192.168.1.xx replace xx with others IP Jun 30 '12 at 14:11
  • @MartheenCahyaPaulo no, i cant.
    – EmRa228
    Jun 30 '12 at 15:29
  • Question: Have you done all the steps as described, for example, here?
    – harrymc
    Jul 7 '12 at 14:15
  • @harrymc yes, see: i.imgbox.com/aas9ehhU.jpg
    – EmRa228
    Jul 7 '12 at 15:39
  • which port are u using for Proxifier? Jul 7 '12 at 18:46

There are numerous factors that can trip up Windows File/Print Sharing. Unfortunately because there are so many factors, it can take some testing to figure out the exact cause in any given scenario.

TL;DR/DIY: Skip to the Summary


Windows Vista changed the way that File/Print Sharing works. Instead of just setting the same workgroup name like in XP, you now have to create a homegroup as well and set the network type (public/private (home)/domain).

Configuring File/Print Sharing should be easy by default, but once you start changing settings or using third-party security software, it becomes quite tricky to make sure everything is set correctly again because there are so many factors.

If you want to share, set the network type to private. If you do not want to share, set the network type to public. It may seem counterintuitive, but it makes sense: in a public network, you want to lock down the sharing settings, but want more lax sharing in a private network.


There are no less than four Windows services that must be running in order for File and Print Sharing to work correctly and fully:

  • Computer Browser
  • Server
  • TCP/IP NetBIOS Helper
  • Workstation

Open the Services MMC snap-in (services.msc) and make sure that those for are running and set to Automatic start. Open Network Places again and refresh. If it doesn’t work, try again in a minute or two.

Personally, I don’t like having all those extraneous services running all the time, even when I’m not using File/Print Sharing. As such, I have created two batch files that let me turn them on and off as needed without having to manually start or stop each individual service:

net start browser
net start server
net start lmhosts
net start lanmanworkstation

net stop browser
net stop server
net stop lmhosts
net stop lanmanworkstation

Adapter Settings

In addition to the service, NetBIOS must be enabled on your network adapter as well:

NetBIOS options for the NIC

While it seems like an obvious step, also make sure that File/Print Sharing is installed and enabled for the active network adapter, particularly if more than one network adapter is installed:

File/Print Sharing Service

Also make sure that the DNS settings are the defaults if you don't specifically need to change them because these settings can affect visibility to and from the LAN:

DNS Settings Dialog

Finally, make sure that the system name and domain/workgroup are configured correctly for your network; for example:

Computer Name/Workgroup Settings Dialogs

NB: Ensure that the computer and workgroup names are valid. The official Windows interface prevents using invalid characters or making it too long, but third-party software does not necessarily prevent that. This can cause problems with network discovery.


Another common cause of File/Print Sharing not working is that a firewall closes a required port. Windows File/Print Sharing requires TCP and UDP ports 135-139 to be open.

Check your security software (firewall, anti-virus, proxy programs) to ensure that the necessary ports are not being blocked. File/Print Sharing has historically been a potential vulnerability and so frequently locked down. You can run a test with ShieldsUP!.

Security Software

Have you installed or changed the settings of any security software like firewalls, antivirus, etc. recently? Those kinds of programs often like to fiddle with various aspects of the OS to lock things down, and if you set "privacy" setting or something, it may block or disable an aspect of Windows. For example, the WWDC (Windows Worms Doors Cleaner) is a great way to harden Windows XP, but setting it to maximum security has the side-effect of disabling F&P Sharing, the Task Scheduler (and thus the prefetcher), etc.

Check your security programs' settings for an option related to sharing.

In addition, make sure the Windows Firewall is configured correctly in case you have changed something a while back. You can compare to a complete listing of (default) Windows Firewall rules for File/Print Sharing from a system with File/Print Sharing functioning correctly.

Misery, Meet Company

Plenty of other people have had similar problems with File/Print Sharing.

All these people ended up having to either modify their network configuration (public/private/home/homegroup/etc.) to match that of the rest of the network, or reset/disable the Windows Firewall (or one of the other items listed in this answer). One person linked to a file that may or may not help fix this issue.

This person had a problem with File/Print Sharing that was fixed by resetting the Windows Firewall rules, and there is also a guide linked in that thread which shows a couple of steps involving changing the default sharing settings that are supposed to help.

In this thread, resetting the TCP/IP stack was suggested as was removing extraneous 6to4 adapters.

Official Responses

Network discovery is a network setting that affects whether your computer can see (find) other computers and devices on the network and whether other computers on the network can see your computer. By default, Windows Firewall blocks network discovery, but you can enable it.

At least as a temporary diagnostic step, turn off your antivirus and Windows Firewall. It is not as simple as you would think; it requires a whole one-minute video to show how to do it.

These people solved it by disabling the Windows Firewall altogether.

Here are two official Microsoft help pages that discuss fixing File/Print Sharing and computers not showing up in a network. They also have two troubleshooters: [1] [2] for resolving these issues.



When File/Print Sharing is not working, make sure that:

  • File/Print Sharing is correctly installed and enabled in all ways: services, NICs, ports

  • All settings are correct and match the rest of the network, including computer and workgroup names, type of network, and network settings

  • Security software (third-party or not) is properly configured, disabled, or uninstalled

If after all this, you system is still messed up and File/Print Sharing is still not working correctly, then you may as well resort to generic fix-it steps like chkdsk, sfc, systemrestore, repair install, or even reinstalling.

  • All services are "started" and "automatic". I also try creating and running "LANOFF.bat" and after that "Lanon.bat". but my problem still has exists.
    – EmRa228
    Jul 9 '12 at 9:44
  • thanks for update your answer, see: i.imgbox.com/aacn9YJh.jpg are ports open? all my firewalls are disable and proxy programs has no effect on 135-139 ports.
    – EmRa228
    Jul 10 '12 at 17:19
  • 1
    "yesssssssssssssss"? o.O Yes what? Yes it finally works or yes you verified it is enabled?
    – Synetech
    Jul 10 '12 at 17:40
  • 1
    Ah, okay. So to be clear, everything is working as expected and the only problem is that other people on the LAN cannot see your computer? Are you behind a router or directly connected to the LAN?
    – Synetech
    Jul 10 '12 at 18:21
  • 1
    Oops, I had it backwards. Either way, it's the same problem; either your network configuration is not set up the same as the rest of the LAN, required software (services/programs) are not running, or something is being blocked. Like I said, double-check your security software (firewall, antivirus, etc.) to make sure you have not set anything that prevents this from working.
    – Synetech
    Jul 11 '12 at 19:29

I understand from the comment that the other computer(s) are not Windows 7, so I assume that they are all XP.

For XP to discover or be discovered by Windows 7 or Vista, it must install :
Link Layer Topology Discovery (LLTD) Responder protocol.

Without this protocol, XP and Vista/7 don't talk the same discovery "language".


Misunderstanding : If all the computers are Windows 7, then there is no software reason for such a problem. So I am left with the following suggestions:

  • Restore to a System Restore Point dating to before the problem.
    Better also verify if a Windows Update has occurred since then, so you may need to block some update.
  • Refresh your network card driver with the latest version from the manufacturer's website
  • Use the System File Checker to verify system integrity
  • Reset the TCP/IP stack :

    netsh int ip reset C:\netsh.log.txt
    netsh winsock reset

In all cases, always take backups before playing with the operating system·

  • 1
    NO, all other computers are windows 7.
    – EmRa228
    Jul 9 '12 at 12:04
  • this screenshot is from another computer in this LAN: i.imgbox.com/aagRRAaH.jpg
    – EmRa228
    Jul 9 '12 at 12:09
  • So basically, just generic diagnostic steps?
    – Synetech
    Jul 9 '12 at 20:28
  • 1
    @Synetech: Yes - according to the info given here I can think of no specific reason for this problem (well, except for virus infection of course).
    – harrymc
    Jul 10 '12 at 5:16

If you did install something that messes with your network services that can very easily have caused this.

Proxifier could be your culprit here as it messes with network traffic - try removing it and go back to a default config.

  • I dont want remove proxifier, have use it. but when I exit it, no change happens.
    – EmRa228
    Jun 30 '12 at 9:50
  • which windows services are for file sharing? and how can go back to default config?
    – EmRa228
    Jun 30 '12 at 9:51

It seems that the DNS for this computer does not work. Please check related settings.

  • Click Start. Enter ncpa.cpl in Start Search box.
  • Right click on the connection you are using, choose Properties.
  • Double-click on the IPv4 protocol.
  • Make sure that IP address and DNS server are set to obtain automatically.
  • If the DNS is already obtained automatically, I suggest that you choose "Use the following DNS server address", and enter the address of your router.

Please check the result. If the issue still occurs, check the hosts file.

  • Click Start, type drivers in the Start Search box, and then press ENTER.
  • Click the entry for drivers that is displayed in the search results. The icon next to drivers will be a folder.
  • A window appears that will display Windows > system32 > drivers in the address bar at the top. Double-click the etc folder.
  • Locate and right-click the hosts file, and then click Rename.
  • Type oldhosts, and then press ENTER. If you receive the following error message click Continue.
  • You need to confirm this operation.
  • If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
  • Restart the computer to make sure that the change takes effect.

If the above solution does not help then try with this solution which involves designation of networks as Public though Network and Sharing Center indicates a Home or Work Network (Private Network).

  • Open Control Panel and select Administrative Tools.
  • Open Local Security Policy and select Network List Manager Policies in the left pane. In the main view, right click your network and select Properties.
  • Select the Network Location tab and change the Location Type to Private.
  • In network properties, ensure that "Client for Microsoft Networks" is checked. If not, check it and reboot.

Hope this helps.

Try by deleting hidden devices from network adapters.

First of all on device manager you must press view > 'show hidden devices'

  • Go to Device Manager
  • Network Adapters
  • Delete everything

Uninstall all of them (some can't be, don't bother). Then press right mouse button at any adapter and check scan for new devices. And if this does not work then uninstall File and Print Services of your network adapter then re-install and reboot.Hope this might solve your problem.

  • solution 1, is ok. solution 2, dosent work. solution 3, dosent work. see: i.imgbox.com/aamm46mM.jpg
    – EmRa228
    Jul 9 '12 at 12:23
  • Reboot and check again. Jul 9 '12 at 14:53
  • I have updated my answer with a solution please try with that and let me know. Jul 9 '12 at 19:47
  • +1 for new way "show hidden devices". they were 230 hidden adapter!!!!
    – EmRa228
    Jul 10 '12 at 17:38
  • Any help after you delete those unwanted hidden adapters? Jul 11 '12 at 13:52

Uninstall and install : File and printer Sharing for Microsoft Networks solved my problem, even if I tried all above and even uninstall and installed NIC driver. (PC on domain)

enter image description here

  • Just Uninstalling and installing : File and printer Sharing for Microsoft Networks worked for me... tried so much other crap before and nothing worked.
    – Jimmy
    Aug 13 '17 at 17:20

Check the firewall settings: Control Panel\All Control Panel Items\Windows Firewall\Allowed Programs File and Printing Sharing checkmarked both columns (Private & Public )? Core Networking? Network Discovery?

go advance and look at the outbound rules.

might try uninstalling and then reinstalling "File and Printing Sharing " from the network adapter. But Rory is probably right about Proxifier

  • Windows Firewall State: OFF; @logman thanks for answer. in advance/outbound rules All items "action" is allowed. I tried try uninstalling and then reinstalling "File and Printing Sharing " from the network adapter, also use another adapter (Local Area connection) In addition WiFi adapter. proxifier: I tried exit it. I still have problem. thanks for new way to solve. this is my screenshot: i.imgbox.com/aaeqeNwz.jpg maybe help.
    – EmRa228
    Jul 7 '12 at 12:22

Update Windows and update your drivers.

  • Tested, working. Mar 13 '19 at 8:56
  • Can you explain why you think this will help in OP's specific situation?
    – bertieb
    Mar 13 '19 at 10:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.