I have an Eee PC 1015PE Seashell netbook running Windows 7 Home Premium with an Intel Graphics Media Accelerator 3150 ( with a "Generic Non-PnP Monitor" detected.

I tried:

  1. Changing the resolution (Control Panel => Appearance and Personalization => Display => Screen Resolution) to 1024x768
  2. Updating the video driver (to
  3. Uninstalling the driver and rebooting
  4. Pressing the Windows Key + "-" (magnifier)
  5. Pressing Ctrl + Mouse Scroll only resizes the desktop items
  6. Pressing Fn + F4 shows 1024x600 (which I think is what I should be using, but nothing happens)


  • Changed from Landscape to Portrait and it works
  • Attached an External Monitor and when I extend or set as desktop it works only on the External Monitor (shows up as "Generic PnP Monitor in Device Manager)

Intel Graphic Media Accelerator Driver for Mobile: Display Settings - Screen Resolution

Basically the bottom inch of my desktop is off-screen hiding my start bar, but my wigets are in their proper position (the start bar is not hidden). Pressing Ctrl + Esc shows the start menu but its cut-off.

I'm pretty sure I should be using 1024x600 resolution, any advice?

What's odd is that this only started happening recently.


  1. Here are some screenshots showing the problem:

Resized Window to fit: Resized window to fit visible area

Opened Start Menu - notice it cut off: Opened Start Menu - notice it cut off

Maximized window and then scrolled down - notice no Start Menu: Maximized window and then scrolled down - notice no Start Menu

  1. I downgraded my graphic driver I downloaded from the Intel Download Center for the Graphic Media Accelerator 3150 (now: and now my "Generic non-PnP Montior" detects as "Digital Flat Panel (1024x768 60Hz)".
  • The work around I have done so far is to rotate my desktop 180 degrees, resize the Menu bar and then rotate back. At least now when I maximize a window it won't go off screen. Still not a solution though. Looks like this: i.imgur.com/JeqQa.jpg – Yzmir Ramirez Jul 4 '12 at 22:10

I fixed this on my computer. Originally, I was thinking this was a harware issue; it is not.

This is an issue with the auto update of the driver. You must go to the ASUS site for your model.

I have the 1015PEM, and this is the link to the driver download page. I downloaded the VGA version V8.14.10.2117 and installed it. This rolled the driver back several versions and when I started the install it asked me if I wanted to go to the earlier version. I clicked Yes, and got all my resolutions back including 1024X600 and it now works.

| improve this answer | |
  • Bad update you say? Makes sense as this problem occurred after a Windows update I believe. This I will try and see if it works ... and boy do I hope it works because I've been using my workaround since this bug. – Yzmir Ramirez Sep 3 '12 at 6:48
  • I tried downgrading and it did not work. Here is a screenshot: i.imgur.com/vzApp.jpg – Yzmir Ramirez Nov 20 '12 at 1:30

Doesn't the netbook have a Fn-Key combination to toggle between lcd monitor, external monitor, both.... kinda thing?

Have you tried cycling through the modes? Quite possible it's set to 'Both', but with nothing external hooked up, windows is getting weird EDID data from somewhere and defaulting to something 'almost right'

Just a thought...

| improve this answer | |
  • Yes, when you press 'Fn + F4' it will cycle though the video resolutions: 800x600, 1024x600, and 1024x768. When I'm in 1024x768 mode and try to go to 1024x600 nothing happens. I just went to the Manufacture's website and downloaded the driver and installed it. Still nothing. – Yzmir Ramirez Jul 1 '12 at 16:28
  • 1
    Well pooh! Back to pondering then I suppose... – lornix Jul 1 '12 at 16:31
  • I think it could be my Monitor that's not being detected properly. Its "Generic Non-PnP Monitor"...perhaps that is what is providing the incorrect EDID (Extended display identification data)? – Yzmir Ramirez Jul 1 '12 at 16:32
  • 1
    hey! flip it around... do you have an external monitor to hook up to it? Does it work properly THAT way? It would help to isolate the problem somewhat. – lornix Jul 1 '12 at 16:35
  • 1
    Odds are that it's a driver issue... you might see if you can "roll-back" the driver... maybe Win7 will let you do that. The current driver isn't sensing the hardware properly, resulting in the "Generic Non-PnP Monitor" situation. – lornix Jul 1 '12 at 16:54

I think something went wrong with your onboard graphical card, so it is not being detected correctly and works with the wrong default driver and wrong resolution. This might also be why the driver installation fails, since it cannot find a compatible video card.

I have not found any way to update the graphical card firmware on your model, so this is best handled by a qualified repair-shop. If the computer is still under warranty, you might be better off using it. Or look for a bad connection somewhere (if you are qualified to do so).

You could also try to force Windows to use the right driver for your model, updating the driver with the "Let me pick from a list of device drivers on my computer" option.

If you wish to play with EDID profiles, you could use PowerStrip, a free utility that can create new custom resolutions for your monitor. You could also use it to investigate the existing EDID information.
See for example : Customize monitor resolution settings with PowerStrip

Be very very careful, as this utility has a real potential to brick the monitor in a very final manner, requiring a good repair-shop to fix, not to mention also void your warranty.

| improve this answer | |
  • I'll try this utility and see if I can change my EDID profile for my monitor and get back to you. Thanks. – Yzmir Ramirez Jul 4 '12 at 19:52
  • I think we're going on the right track here. I ran the PowerStrip utility and went to the monitor profile and noticed that I couldn't change the resolution beyond 1024x768. Clearly its the Monitor that isn't being detected. I tried to get my EDID info from the monitor but DDC wasn't enabled or supported. i.imgur.com/0d7TY.png So then I uninstalled the Monitor driver and installed the latest driver from Eee Asus's (version 14.10), website here: usa.asus.com/Eee/Eee_PC/Eee_PC_1015PE_Seashell/#download and still nothing. – Yzmir Ramirez Jul 4 '12 at 22:25
  • Updated the Display adapter (Intel Graphic Media Accelerator 3150 to - the latest), and still nothing. – Yzmir Ramirez Jul 4 '12 at 23:09
  • I still think that this is a hardware problem with the video card or monitor. But if PowerStrip can't setup the right resolution, then nothing can. I anyway find it puzzling that PowerStrip can't go beyond 1024x768, as I thought that it is supposed to allow "illegal" resolutions. – harrymc Jul 5 '12 at 5:33
  • I found that odd too, but maybe that's because I didn't purchase the full version? Clearly its a hardware issue with the Monitor not properly being recognized. Using an external monitor works just fine btw. My guess is when I did one of the Windows Updates or SP1 perhaps, not sure, is when this problem started occuring. I was thinking of upgrading BIOS and other things like that, but really is a $257 netbook worth it? Now don't get me wrong, I want to know why and fix it, but its like putting gull wings on a dog sled. – Yzmir Ramirez Jul 5 '12 at 19:05

Same Problem here!

Surfaced after I connected to a TV via VGA Cable (viewing Pics @Friends).

Solution: I connected again an external Monitor, waited until pnp finished its Job, switched to 800x600 and rebooted with the Lid closed.

Now I have my 1024x600 back!

Seems to be a bit buggy designed :-)

| improve this answer | |

I have the same model and the same problem. It happened today when I restarted and windows update kicked in. System restore, changing display settings, and everything you've already outlined here were all useless.

Halfway through updating the VGA driver, the normal appearance returned for a second, then back to this cut off look. Also getting "Generic non-PnP Monitor" in the device manager. I have not attempted anything with PowerStrip yet. However, I do know that I'm unable to go past 1024 x 768 from

Control Panel -> Appearance -> Display -> Screen Resolution

despite a higher setting showing up on the resolution slider when hooked up to an external monitor.

Thankfully I have an external monitor to fall back on as I try to cram for an undergrad physics final on this thing, but do know that at least one other person has the same problem (likely many more), and so if you find a solution, posting it would be much appreciated.

| improve this answer | |
  • The only work around was to invert the screen by going to the Graphic settings and resizing the start bar (no-hide), so that it fills up the gap. I'm been doing that for a week now, and still haven't found a solution from the manufacturer service.asus.com/ProductCategory.aspx?pid=2 – Yzmir Ramirez Jul 10 '12 at 1:20
  • Yzmir: since my first post, the onboard display has cut out entirely. It does seem like a hardware issue, but somewhat too convenient in light of windows update's propensity for creating problems. I'm not under warranty, so once I'm done mucking around with BIOS and software-based fixes, I'll crack the case open and see if I can find a damaged or loose connection. – Jeremy Jul 10 '12 at 23:00
  • I'm thinking about doing that, but I'm getting by by moving changing the start bar's height like this - i.imgur.com/vzApp.jpg – Yzmir Ramirez Nov 22 '12 at 4:36

Try rolling back your video driver to the one that was installed back when things were working correctly. This does NOT mean getting an earlier version from Intel, it means finding the original driver package installed on the computer as it came from Asus, which should still be in your Driver Store. Typically, the drivers for Intel integrated graphics have been modified in one way or another by the comp. mfg. and are not interchangeable with the generic drivers provided by Intel. It is a bit of common wisdom to NEVER let Windows update handle anything other than Microsoft products.

| improve this answer | |
  • I tried going back several versions...even the original version. Here I'm using 2117 and its still not working - i.imgur.com/vzApp.jpg I even did a CLEAN install (you can do that by pressing F9 and going though the wipe process during boot). – Yzmir Ramirez Nov 22 '12 at 4:37

I believe this is display hardware problem, beause it shows cut-screen even in BIOS. Display is detected as 4:3 instead of wide-screen. In my case I may resolve this in 2 way:

  1. Restart my EEE PC with closed lid (monitor cable problems?), if that does not help then

  2. Shut down and wait for 5-10 minutes (overheat problems)

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.