I have an ASUS WL-520GU wireless router with four LAN ports.

When my laptop is running Windows 7, and I make a wired connection from the laptop to the router, the laptop does not get an IP address. The network and sharing center calls it a "Public Network" with "Limited Access" and when clicking 'status' it says that there is no ip address for IPv4 nor IPv6.

However, the following things do work with the same router:

  • Making a WiFi connection from same laptop with same OS
  • making a wired connection from same laptop running Ubuntu
  • making a wired connection from a different PC running Windows PC *

I have repeated the experiment several times: reset router to factory settings, connect no other device with lan nor wan, connect laptop in question, get no IP address.


I have just realized that the behavior is not as regular and predictable as I first thought. It seems that the router has problems in general with DHCP. I have tried, within the last few days, without any restarts of the router, that one laptop said upon login that the IP was already used by another PC.

After posting this is what happened:

  1. Suddenly the laptop was not even able to get an ip over WiFi
  2. I restarted the laptop and reset the router to factory settings
  3. I connected to router over WiFi and got an IP
  4. I disconnected WiFi connection, connected wired, and got IP address
  5. I disconnected wired connection and reset the router to factory settings
  6. I was not able to get an IP with neither wired nor wifi. I tried several times.
  7. Suddenly (without restart or reset) when both WiFi and Wired connection was established I got an IP address.
  8. I restarted the router but now I kept getting IP addresses successfully with both wired and WiFi, ie could not provoke the problem.

In short, I can't really see a pattern in this behavior.

  • You've done a good job troubleshooting this and posting the information with your question. Windows 7 seems to like to treat some routers as devices which can be harmful. Have you tried changing the network location to Home or Work? It should then "trust" your router to allow a connection. – CharlieRB Jul 2 '12 at 18:52
  • Short update: I realized that the behaviour is not as 'simple' as I thought it was. I am doing a few more experiments and, I will update this post. – Mads Skjern Jul 2 '12 at 19:16
  • What does it say under ethernet connection when you do ipconfig in the command prompt? – Der Hochstapler Jul 2 '12 at 19:42
  • Right now I am not able to reproduce the problem at all, but when I have reproduced, I will post the ipconfig result. – Mads Skjern Jul 2 '12 at 19:44
  • After a few days, the problem has not reoccurred. But it happened many times over the last few months so I'm sure it will happen at some point. Thanks for all the advice. – Mads Skjern Jul 5 '12 at 18:08

In my case the router, serving as a DHCP server, had too small a range of IP addresses configured, so the new computer couldn't get an IP address as they were all taken up by other computers. Increasing the DHCP IP address range fixed it:

enter image description here


Things to try:

  1. Make sure that all devices on the same network do not have static addresses set up. This could mean TV's, phones, game consoles as well as PC's. (Make sure that both Wireless AND wired Network interfaces on your computers are set to Dynamic addressng too..)

  2. Once you are absolutely sure that no devices have static IP addresses, make sure that your router has no DHCP reservations.

  3. Press windows key + R and type "cmd" into the textfield, then press Enter.

  4. Type: ipconfig /release

  5. Then type: ipconfig /renew

This should be enough to fix the issue, but if not please post your "ipconfig /all" results please.


Not the answer you're looking for? Browse other questions tagged or ask your own question.