I'm reinstalling Windows 7 64 bit, and I encountered an issue I've never seen before. I have a legit copy of Win 64 Professional, and I've installed it probably a half dozen times on this machine in the past without a problem.

Googling the error only brings me to issues with people who are upgrading to win7.

The drive itself seems to not have a problem. I can mount it on other systems and I can create an NTFS partition on it on other machines. I can install Ubuntu on it without any issues. Additionally, if I try using my alternate backup hard drive, the installer gives the same error.

I have run diskpart from the setup page and clean seems to report that all is well. However, I cannot get past the screen below, which says Setup was unable to create a new system partition or locate an existing system partition. This happens regardless of whether or not the disk space is already allocated.

What is causing this? How do I solve or get past this?

A strange error appears

Edit: One Week Later

I am at my wits end with this... I have tried installing windows on four different hard drives, using two completely different motherboards, I even borrowed a copy of Windows 7 Ultimate as well as my legit Win7Pro disk. I have tried with no existing partitions, and with existing (and fully functional) NTFS partitions. I've tried installing off of USB and DVD. Every time I get to the screen shown above I get the same result.

  • Is this a removable drive? Windows doesn't like installing on a removable drive...
    – lornix
    Commented Jul 2, 2012 at 21:29
  • It is a SATA HDD, connected to the SATA ports on the motherboard
    – hughes
    Commented Jul 2, 2012 at 21:39
  • @pinouchon can you grab the setuperr.log file? Commented Aug 23, 2015 at 6:16
  • Check out this question as well! It contains other solutions for the same problem. I had to update my BIOS to get past the error. Commented Dec 8, 2018 at 15:32

8 Answers 8


I got it to work.

What I did:

  • Remove all USB devices except the keyboard
  • Set the boot order in the BIOS so that the HDD is first
  • Disconnect the network
  • Use a DVD (not usb) for installation

I had tried each of these things individually and in different combinations. I'm not sure why it suddenly worked now, but windows setup was suddenly able to create a partition.

  • All I had to do was disable all other hard drives in bios then it installed like a charm without any errors. Commented Mar 20, 2013 at 5:06
  • 3
    Thanks for this; I was literally tearing my hair out because my brand new laptop would not install Windows 7 from a USB key (I had to use the DVD drive!). For people who want to remove their DVD drives, you might want to consider installing a clean version of Windows 7, and cloning/ghosting the partition for future use. Commented Apr 27, 2013 at 14:49
  • I was stuck on the same problems after hours of research... What I did: removed all unnecessary connections: mouse, ethernet port, printer, other usb keys. I left only: power, keyboard, monitor, bootable usb. In the BIOS, I also changed the boot order so that the SSD (where I install) is first and the bootable USB second. Then I booted the USB by pressing F12 and manually selecting USB. Some other plugged device was causing the issue... You get a bounty for pointing me in the right direction. Commented Aug 19, 2015 at 12:19

Checked your BIOS settings lately?!

Sometimes there is a section in your BIOS regarding something like "Boot Sector Virus protection." And it's usually a good idea to leave this setting enabled for normal use too. But you probably want to disable it when installing a new Windows operating system.

FYI: Other file systems like those used with Linux aren't usually even looked at by a BIOS. In fact, if you even have this BIOS feature then it will almost exclusively look for a NTFS or FAT file system only (and make sure it isn't messed with). That would explain why you can establish nearly any other filesystem and why you can't create a new Windows NTFS file system.

  • Thanks for the suggestion! I wasn't able to find any BIOS setting like that. My motherboard is a MSI 790FX-GD70.
    – hughes
    Commented Jul 7, 2012 at 2:03

Do you have MBR or GPT? - since you have less then 2.2 TB drive you can safely use old MBR and installer will more likely cooperate with you..

shift+F10 will open command prompt - use diskpart to convert to MBR

Also drivers to storage controller on pendrive is good option (load driver)..

  • Unfortunately, converting to MBR did not help.
    – hughes
    Commented Jul 7, 2012 at 2:12

Use a linux live cd that has parted magic, and make sure all partitions are removed. Make sure any hidden partitions are gone. Cleaning should have done it though.


Have you tried manually creating a new partition? If you set it to use all the free space, it should bring up a message saying it needs to create a partition for the system files

  • I have tried that. I recall it asked me that on previous installations. However I do not see it now. It lets me create a partition of any size and does not ask for a reserved system volume. When I leave space for a system volume, it does not use it.
    – hughes
    Commented Jul 2, 2012 at 21:40
  • Even if you try setting it to use all the free space for one partition? Hmmm.... Commented Jul 2, 2012 at 21:40
  • Yeah. Every time I've installed windows 7 in the past it has asked for a reserved system volume, but not now
    – hughes
    Commented Jul 2, 2012 at 21:49

Find a way to change the partition table format back to MBR; I ran into issues like this when I had a GPT-formatted partition table. Windows is supposed to have support for GPT disks, but the installer didn't want to have anything to do with it when I was using it.

  • I tried converting the disk to MBR using diskpart. Unfortunately it didn't help.
    – hughes
    Commented Jul 7, 2012 at 2:13

On some Intel motherboards, you can change SATA Operation from "Intel® Smart Response Technology" to AHCI, and then you can install W7 normally.

I don't know after that if you can change back after W7 installation yet...


In my case, there was an SSD with an old Windows install (incl. System Reserved partition) on it connected whilst I was trying to install Windows on a HDD. Unplugging the SSD resolved this error.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .