1

I just installed - and updated - Fedora 17 on my vaio VGN-CS170F laptop. Everything works fine, except when I close the lid it goes to sleep, and when I open it back, the keyboard becomes unresponsive (the mouse pad works just fine).

I'm running

 Linux vaio 3.4.4-3.fc17.x86_64 #1 SMP

Any hints ?

4
  • You are using the built-in keyboard, correct?
    – imtheman
    Jul 5, 2012 at 21:17
  • That's correct.
    – xain
    Jul 5, 2012 at 22:19
  • Do you know whether the keyboard is using a special kernel module? You can use the lsmod command to check what modules are loaded.
    – Izzy
    Jul 6, 2012 at 13:02
  • A pity there is an unresolved forum post for this at forums.fedoraforum.org/showthread.php?t=272752 :/
    – invert
    Jul 11, 2012 at 9:51

4 Answers 4

3

That seems to be a bug with your keyboard. Here's the solution I found:

To automatically rebind keyboard after resume, open your /etc/default/grub file with your favorite text editor and and append atkbd.reset to the kernel line, like this:

GRUB_CMDLINE_LINUX="... atkbd.reset"

Don't forget to run grub2-mkconfig. Consequently, the system will take care of resetting the driver on resume.

(Source)

4
  • Did what you said with no luck; anyway the modules loaded are in pastebin.com/jMNQicCz. Thanks
    – xain
    Jul 6, 2012 at 22:50
  • Sorry to read that. I also checked your modules list, but found nothing which looked like pointing to your kbd. If it were, you could have tried to mark that for automatically unload (on sleep) and reload (on wakeup), using the SUSPEND_MODULES setting.
    – Izzy
    Jul 7, 2012 at 20:26
  • I know this is old - but cheers, it worked for me. Oct 7, 2014 at 3:27
  • Worked for me. Why was this still happening in the year 2020?
    – macetw
    Jan 30, 2020 at 18:12
1

I had this exact same issue and got it sorted out!

Basically, run this in a shell to confirm you are applicable to this solution:

dmesg | grep i8042

and confirm you get this output

[ 1.514469] i8042: PNP: PS/2 Controller [PNP0303:KBC,PNP0f13:MOUE] at 0x60,0x64 irq 1,12
[ 1.525273] serio: i8042 KBD port at 0x60,0x64 irq 1
[ 1.525287] serio: i8042 AUX port at 0x60,0x64 irq 12
[ 1.526035] input: AT Raw Set 2 keyboard as /devices/platform/i8042/serio0/input/input3
[ 21.927438] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input10

then, add the following to the Kernel line in grub boot (either during boot or grub.cfg):

i8042.direct i8042.dumbkbd

This guy here, solved my issue. And he is from 2007! Incredibly, this issue was still happening today: https://ubuntuforums.org/showthread.php?t=2224316

2
  • 1
    Welcome to Super User. I was going to post a wise-ass comment about a time traveler fixing your issue, but realized that everyone on the site is likely from 2007 if you don't mean moments ago. :-) But external links can break or be unavailable, in which case your answer would not be useful. Please include the essential information within your answer and use the link for attribution and further reading. Thanks.
    – fixer1234
    Jul 27, 2017 at 1:47
  • 1
    Thank you @fixer1234 this is a good idea. I am actually storing it in dropbox for the next 10 years :)
    – Saif
    Jul 27, 2017 at 12:20
1

Append i8042.dumbkbd to your kernel line temporarily.

  1. Reboot
  2. Press e when the kernel selection menu appears
  3. Find the kernel line by searching for the word vmlinuz or quiet
  4. Append i8042.dumbkbd to the end of the kernel line
  5. Suspend and resume then check that the keyboard works: sudo systemctl suspend

Append i8042.dumbkbd to your kernel line permanently.

sudo vim /etc/default/grub
     GRUB_CMDLINE_LINUX="... i8042.dumbkbd"
sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

Here is the complete list of i8042 quick options.

0

Not at all sure if this will help, but seems like certain kernel versions had suspend/resume issues. As a test, try adding acpi_sleep=nonvs to your kernel line on boot, and try suspend/resume.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.