I just got my Mac upgraded to 10.7.2, just to be able to install Xcode 4.3.3.

However, when I try to install Xcode 4.3.3, it says that it requires a minimum of OSX 10.7.3.

Then using the "Software Upgrade" tool it detects successfully for me that a combined upgrade to 10.7.4 is available. As I select Install Item, the download starts however, it fails after complete download (taking two hours) saying something like "the update cannot be saved".

I have done this twice already, and followed it up until 5 minutes were left. I have also checked that there is enough space (60 GB) available on my hard disk, while the update requires around 1.5 GB.

The question is what is causing the problem mentioned in bold above.

3 Answers 3


The fact it's taking so long and failing at the end indicates that you are using airport and you havn't restarted your mac for some time. For some reason airport cards go a little bit skew-iff after being on for a while.. They work but not well.

The problems present themselves in different ways. When it happens on my mac, for example, everything works most of the time except aol messenger, though I almost always have issues with http downloads.

Don't downvote with out trying but... Turn it off and on again... That should hopefully assist with the download issue. If this is still causing you problems please post back and I will try to help you diagnose further.

  • It actually worked after a restart, even before reading this answer! Jul 3, 2012 at 10:12

Sometimes something wrong happens with Software Update (generates corrupted files). Did you try to perform update manualy by downloading Combo Update

  • It worked without this, but I was looking for something like this. Jul 3, 2012 at 10:13

First install !0.7.3 combo update


Then install 10.7.4 update


  • It worked after restarting, but I was looking for something like this. And actually wanted to install 10.7.3 first, but I was told that 10.7.3 was sort of called back by Apple, not in the literal sense but 10.7.4 appeared quickly Jul 3, 2012 at 10:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .