2

I have a problem with browsing samba shares with Nautilus in Ubuntu. I can see work groups but cannot go any deeper.

On the other hand, I can use smbclient and mount samba shares from command line. Also I can browse Ubuntu shares from Windows but not vice versa.

So I suspect it is Nautilus problem. Moreover it has never been working for me since I first started using Ubuntu.

Systems I tried to browse shares on:

  • Ubuntu 8-12
  • Windows Xp 7
  • Dune HD Max

Could someone provide me with ideas how to diagnose this issue? Or describe how network browsing is implemented in Nautilus.

1
  • I have the same issue, but no luck so far. – Eusebius Oct 11 '12 at 13:40
1

This solution worked for me: if smbtree returns an error instead of a listing of your network environment, edit your /etc/samba/smb.conf and modify the following line:

; name resolve order = lmhosts host wins bcast

which should instead look like this (uncommented and host at the end):

name resolve order = lmhosts wins bcast host

Apparently you need to reboot after that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.