13

The browser URL autocomplete has started behaving differently starting yesterday.

I used to access my top urls by typing the first one or two letters of a URL then pressing enter. Now, I have to visually fish for the right one and push the down arrow to select the url. Big difference.

Anybody know if I can get the old functionality back somehow? Have I messed a setting?

Example of how my browser used to work:

Gmail.com:
CMD + L
Type G
Enter

Stackoverflow.com
CMD + L 
Type S
Enter

enter image description here

Normally, the browser bar would already be highlighted with gmail.com after typing the first g. It would narrow the matches depending on what characters were typed next, or simply go to it if I pressed enter.

UPDATE: I just realized my history tab looks suspicious. No entries

But clearly Chrome is pulling some data from my history, as I have very personalized recommendations when typing in a letter.

enter image description here

  • What were the first entries replaced with? Could you provide a screenshot of an example maybe? Thanks – Der Hochstapler Jul 4 '12 at 17:57
  • @OliverSalzburg done – Yuji Tomita Jul 4 '12 at 18:05
  • what version / channel are you on? Did you change anything in chrome://flags? Or chrome://settings? It's working fine here, on Stable & dev channels – Sathyajith Bhat Jul 4 '12 at 18:58
  • 3
    Have you cleared your browsing data recently? Because that will do it. – imtheman Jul 4 '12 at 20:47
  • @PeterMaxwell, indeed I did at some point last week. Maybe I only noticed this a few days ago, in which case I'd be supremely happy. I've yet to see anything pre-filled in the address bar. – Yuji Tomita Jul 5 '12 at 7:07
6

Saved my bookmarks, removed my ~/Library/Application\ Support/Google/Default directory (careful, it looks like absolutely everything is stored here) restarted chrome, and within one visit to Gmail.com, my autocomplete was filling in my URLs like so:

enter image description here

Beautiful.

| improve this answer | |
  • What I did was rename the Default directory to Default.save, just in case. Opened Chrome. Yes, URL autocomplete was working, but after sign in, info was missing in some of my extensions. So deleted new Default and renamed the old back to what it was. URL autocomplete still working and I have all my stuff. – subjectivist Aug 18 '18 at 19:27
1

It seems chrome crash will cause this.

Here is what I did to solve that:

  • close chrome
  • remove -rf ~/.config/google-chrome/
  • restart chrome
  • re-login to chrome to restore things like theme,
  • now, the auto fill should be working.
| improve this answer | |
1

This happened to me and when I checked on Use a prediction service to help complete searches and URLs typed in the address bar in Settings > Advanced Settings the box was unchecked and disabled. There was a puzzle piece next to it explaining Privacy Badger had shut the service off.

| improve this answer | |
  • This saved my time and effort, was suppose to try removing ~/.config/google-chrome :D – Vaishak Jan 26 '17 at 5:40
-1
  • Open chrome://settings
  • Go to Privacy and security in advanced options
  • Check for the options in the image

Ensure that the "Use a prediction service to help complete searches and URLs typed in the address bar" toggle is turned on.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.