First off, this computer is not mine, it's a customer's system. Having said that...

The hard drive was moved to a new motherboard, CPU, RAM combo, and booted up fine. Customer puts in driver CD, drivers won't load. He brings it into me.

Under Device Manager for Windows 7 x64, I see lots of PCI to PCI bridge, one SMBus Controller, and about 20 Unknown Devices. Greeeeeat... So I start with the SMBus driver directly from the Asus website for the motherboard (P8H77-M Pro). If I install from the setup program, it tells me to reboot, then it starts the install. It gets half way through the setup, then fails (An unknown error occurred. Setup will exit). When I try to point to the folder from Device Manager, it starts copying files for the driver, even presents me with the proper name of the device, but says that an error has occurred there as well: The directory name is invalid.

Doing some Googling, I saw that many people had this issue with Vista. K, Vista and 7 are similar, maybe the solutions are the same... But they aren't.

I tried:

  1. Copying the entire driver folder and setup utility to the Program Files folder and running it / selecting it in DM
  2. Downloading another set of drivers in case this one is corrupt
  3. Disabling UAC
  4. Deleting and recreating the %WINDIR%\TEMP folder
  5. Removing all references to previous hardware that I could find, even in Device Manager's hidden mode
  6. Creating a new Admin user

So far, nothing has worked. A wipe and reload will be out of the question.

EDIT I am going to try a repair install and see if that works

EDIT 2 It looks like the hard drive has errors... Imaging to a new drive then testing

EDIT 3 Hard drive is fine. Customer has decided that I know what I'm talking about when I say he needs to wipe and reload. Thanks for all the help, but since this is currently unsolvable in its current form, I'm voting to close as too localized. I will not take offense if others follow along

  • Try and find out what directory name it thinks is invalid. You might use resmon or processexplorer (ms website) or process monitor (ms website). If this occurs after forced system reboot, the latter 2 you might need to run automatically after reboot by placing a shortcut in the startup section. – horatio Jul 5 '12 at 19:14
  • One other comment: you might have better luck getting an installer from intel directly (assuming it is an intel chipset) – horatio Jul 5 '12 at 19:20
  • @horatio I can't find the installer from Intel for THIS chipset (H77 chipset). If you can find it and link it, I'll try that – Canadian Luke Jul 5 '12 at 19:26
  • nor I, But I do note that the asus package has many folders and the ini files reference relative paths, some even back out a level. the win7 one has a hotfix folder. Perhaps follow the trails in those ini files to find the right package level and then run that one, rather than the top-level setup executable. I can envision a scenario where files are unpacked to a temp folder and then the CWD is not what was anticipated and the tree structure is wrong. – horatio Jul 5 '12 at 20:30
  • @horatio Not sure... I unpacked the files already and tried the SETUP and the Asus install, no change – Canadian Luke Jul 5 '12 at 22:00

This doesn't seem like a common problem with Windows 7, but it sounds like it has something to do with the temporary folder.

Try this:

  • Since you mentioned recreating %WINDIR%\TEMP, make sure it has proper permissions as explained in this KB article.

    It is for specific problem with Vista, but the part about permissions should still apply.

  • Run set t in a command prompt to see the locations of %TEMP% and %TMP% (usually %USERPROFILE%\AppData\Local\Temp for both).

    Check those folders for existence and permissions.

  • If nothing else helps, try creating a new user with Administrator privileges.

  • Folder exists, current user (And System, and Administrators) has Full Control. Created new Admin user also did not help (same errors) – Canadian Luke Jul 5 '12 at 17:14

As stated many times here. The best (and most reliable) option is do a clean install when moving your OS HDD to a new computer.

  • I agree, but this customer is very f*ing stubborn, and will not accept a clean install... Although I can still charge for all the time I'm putting into it when he won't just accept a wipe and reload :P – Canadian Luke Jul 5 '12 at 18:50
  • Oh, one of those... I'm sorry man. I work in IT and deal with people like that all day. So I feel your pain. – imtheman Jul 5 '12 at 18:52
  • Do you by any chance have access to the old computer? – imtheman Jul 5 '12 at 18:55
  • No access to the old one. Imaging hard drive for Repair Install – Canadian Luke Jul 5 '12 at 19:26
  • Oh ok, the repairing should do the trick. – imtheman Jul 5 '12 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.