I changed the DNS servers on my Wireless Router to OpenDNS. However, when I test it out using digg (from my Linux machine) as described here it does not give me the expected "SERVER" IP address.

There is a cryptic thing on there about "maybe your ISP does not allow third party DNS". How would that be possible? It seems that DNS is just communication between my router and the DNS server... how would the ISP be involved and blocking that? And how do I check it out (i.e. what question should I ask my ISP)

  • 2
    What is your ISP? – Col Sep 21 '09 at 16:02
  • Cavalier / Phonom – JoelFan Sep 21 '09 at 20:36
  • 1
    This link is a little dated, forums.mozillazine.org/…, but it looks like they haven't been shy about DNS hijacking in the past. – hyperslug Sep 21 '09 at 22:13

The ISP can block outgoing UDP requests to port 53 to all addresses except its own DNS servers.

| improve this answer | |

It's certainly possible... What could be happening is that your ISP is blocking traffic to / from Port 53 (typically DNS) to all other sites other than their own DNS servers.

Either that or your application or DNS configuration maybe incorrect.

What would you ask your ISP, are you blocking DNS traffic and/or port 53.

| improve this answer | |
  • 1
    Or ask straight up if they allow 3rd party DNS like OpenDNS. I guess if a lot of ISP's start figuring out that advertising on landing pages generates revenue, they might start doing this. – hyperslug Sep 21 '09 at 16:29

I found the problem... see this question

| improve this answer | |
  • I can't believe we never asked you to check for manual DNS settings. (hangs head in shame) – hyperslug Oct 2 '09 at 14:03

I ran into this issue. This is what I had. My fios router was setup in bridge mode and i was using linksys router which was getting WAN IP via DHCP. I had setup Opendns dns on LAN but it was not working as expected. what i found was i had to setup opendns on linksys WAN staticly to make it work without any issue. i had to do the following to get around this

i setup fios router as normal. changed the LAN ip range on fios router to 192.168.2.x and disabled dhcp. connected linksys to fious router and change WAN ip on linksys to static in 192.168.2.x range and assigned OPENDNS entry manually. connected everything else on linksys and it worked.

If you decide to use this setup, do not forget to disable wireless on fios router or setup some security on it.

I hope this helps.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.