I have a pendrive when I insert it into one o my port it shows in the My Computer but when I try to explore, it shows please insert a disk into drive H. However my usb drive is well inserted. I tried to format it but it is showing There is no disk in drive H, Insert a disk then try again. Its properties is showing Unknown File System and the used space and free space part showing 0 bytes. I cann't also check for errors in the drive. Its device status:The device is working properly. I also reinstalled the driver but that did not help me. Please suggest some way to recover the issue.

  • Could you clarify your OS?
    – ephsmith
    Jul 6 '12 at 14:06
  • @ephsmith I added the generic Windows tag because of "My Computer" and drive "H".
    – Matteo
    Jul 6 '12 at 14:08
  • @ephsmith Its definitely Windows according to the Error Messages. Jul 6 '12 at 14:09
  • Semantics... It'a clearly Windows. I guess I should've been more clear. Which version of windows. ?
    – ephsmith
    Jul 6 '12 at 14:15
  • its windows xp sp3
    – Deb
    Jul 6 '12 at 14:43

In most cases what you have to do (I'm assuming you have some version of Windows XP +) is go into CONTROL PANEL > ADMINISTRATOR OPTIONS > COMPUTER MANAGEMENT > Disk Management and then FORMAT the visible drive (usually you might have to delete the partition if something happened to the drive that resulted in corrupt/invalid data). I've had this happen before when formatting a USB to be bootable, it might fail and not mount properly after.

This trick via the management panel, will allow you to manage all your drives. Only formatted drives will show up under MY COMPUTER.


There is a process you can use to format unreadable drives from the command line, I often find it necessary on USB pens that are causing me real headaches.

Open up CMD (open it as administrator if you're running Windows Vista or 7 and UAC) and type the following:


In the prompt type in:

list disk

This will present a list of disks, e.g.:

DISKPART> list disk

  Disk ###  Status         Size     Free     Dyn  Gpt
  --------  -------------  -------  -------  ---  ---
  Disk 0    Online          149 GB      0 B
  Disk 1    Online         7751 MB      0 B

As you can see from the example I have a 150GB disk, disk 0, and an 8GB disk, disk 1, being the USB pen. The next step is completely wipe the USB device:

DISKPART> select disk 1

Disk 1 is now the selected disk.


DiskPart succeeded in cleaning the disk.

Finally we need to create a primary partition on the disk and format it, in this case as fat32:

DISKPART> select disk 1

Disk 1 is now the selected disk.

DISKPART> create partition primary

DiskPart succeeded in creating the specified partition.

DISKPART> format fs=fat32 quick

  100 percent completed

DiskPart successfully formatted the volume.


Once you've completed the above steps you should have completely reformatted your USB and it will be ready for use.

N.B. if you get access denied at any point during this process it is likely that you need to run the CMD prompt as admin.

  • I tried this option but I am getting only one disk that is my hard disk only. I have two USB's one is working well but neither of them is showing in my command prompt. The USB which is working well, should be showing in the prompt but it is not showing.
    – Deb
    Jul 6 '12 at 15:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.