I'm using a GeForce GTX 580, with Windows 7 64-bit. The driver version of the GTX is 301.42. The problem happens after a few minutes, when I'm playing specifc games. It won't happen in all games - And I don't have any idea why these games doesn't work.

The games that doesn't work:

Battlefield 3, Civilization V, Sniper Elite V2.

The games that work:

Mass Effect 3, Crysis 2, Team Fortress 2, Left 4 Dead 2, Skyrim, L.A. Noire.

As you can see, it's not a problem of "The games that demand more stop working".

I've tryed updating the driver of the graphics-card, the bios of the motherboard, even formated my computer (It was needing it) and instaled every driver in the last version possible.

This problem happens since I bought my graphics-card, 6 months ago. After a few minutes, from 10 to 20, the pixels in the monitor become strange, with random colors and effects, like it was broken. Then, everything goes black, and the message appears "Display Driver has stopped responding and has recovered".

After that, I need to close the game and start again. I am not overclocking, and my temperature never goes higher than 70ºC.

| improve this question | | | | |
  • 1
    Have you tried an older graphics driver? Are you running more than one monitor? – Shinrai Jul 6 '12 at 20:26
  • Only one monitor. And before I formated my computer, I was running a out-dated version of the driver. But I will try again, who knows. – Vitor Rangel Jul 6 '12 at 20:30
  • If the pixels on the monitor become strange, then that's most likely memory corruption, which will cause the card and driver to crash, resulting in the "stopped responding and recovered" message. Whether that's due to bad video memory, bad system memory, or a bad driver is still a question though. – Darth Android Jul 6 '12 at 21:53
  • I tryed with 295.73, a older version, and the same happened. With the beta 304.79, witch teorically fixed a issue with Civilization V, nothing changed. The same error, over and over again. But it took a longer time to happen. – Vitor Rangel Jul 6 '12 at 22:29

It could be due to lack of voltage, I have only come across this when overclocking but it could occur at stock voltage and clocks. Get evga precision X or Msi Afterburner and lower the clock speeds through either one of those applications and see if that stops the crashing, if it does then get a custom bios and increase the voltage so it will run smoothly at stock clock speeds.

| improve this answer | | | | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.