10

The girlfriend's computer is giving me a headache.

It's a relatively new computer, less than a year old, Windows 7. She connects over wi-fi to Uverse. She uses Firefox, the latest version and has the AdBlock Plus plugin. She complained that her computer was slow, so I took a look. Firefox starts up fast enough and loads Google as her homepage. Trying to search for something is painfully slow. Bing, Yahoo and other sites load quickly.

I can ping google.com. Netstat shows me connections to Google servers, but pages never finish. When she tries to sign in, the image on the bottom left of the Google login form never loads.

I disabled AdBlock, but that doesn't help.

I opened up IE and it loads Google pages with no problem. I installed Chrome and it works fine too. It's just Firefox and Google.

Right now she's using Chrome and giving me dirty looks for not being able to fix her computer. Can anyone help?

  • I have same problem... Sometimes I wait about 1 minute to load Google.com and other Google products (Youtube, gMail, Google Docs etc) and if in same time I open Chrome, it loads the page in less than two seconds. – Ionică Bizău Apr 4 '13 at 17:42
7

I have no specific idea what could cause this, but it might be related to Google using SPDY, so you might want to check if other SPDY enabled sites like Twitter have the same problem or if the problem stays when you disable SPDY in Firefox by opening about:config in the address bar and setting network.http.spdy.enabled to false. Testing with a new profile (by running firefox.exe -p) would also be interesting. If this does not help the problem is rather in a anti-malware product or similar, that hooks HTTP connections. A proxy also might cause problems. For more generic troubleshooting hints for Firefox see http://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems.

0

I played around with this problem for a few days. Try disabling Adblock from your add-ons. If it works use uBlock from the list of add-ons in Firefox. The speed is increased enormously.

  • 1
    Can you give more information in order to help other users? – yass Apr 15 '17 at 18:31
-1

I have HTTPS everywhere installed and Google sites were slow. Click on the HTTPS icon, click Google APIs (to turn it off) and restart Firefox. Much faster!

  • 2
    But then encryption isn't necessarily enforced which is a bigger problem. – Enigma Mar 17 '16 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.