I cannot seem to install the correct boot loader for a non-UEFI firmware system. I'm trying to install Ubuntu 12.04 and Windows 7 (64) which are technically compatible with GPT but for windows only if the firmware is UEFI enabled. My system uses the old BIOS system and does not support UEFI. Therefore, whenever I finish my Ubuntu install and try to install Windows I get a "cannot install to GPT partition type" error.

Even if I use Gparted to format a special NTFS file format for windows it can't handle the GPT partition style because it doesn't have UEFI. But my ubuntu install always forces GPT during installation and never asks if I want to install the old BIOS style MBR instead.

How do I resolve this? Both OS's will install fine on their own the problem is when I try to install the second OS it doesn't recognize any of the other's partitions and tries to rewrite it's own on top of the other. I've tried both OS's first and always run into the same problem. Since there is no way to make Windows recognize GPT without upgrading my Motherboard how do I tell Ubuntu to use the old BIOS MBR on install?

Do I have to download a special Ubuntu with a specific grub version? or should I manaually configure my partition somehow to force it not to use GPT?

Thank you,

  • I actually ended up fixing this problem by installing Windows first. Then shrinking it's partition with the partition manager in Windows. I installed Ubuntu (after having to edit the launch config to boot into low graphics mode) then installed Ubuntu. The boot loader never ended up getting installed correctly so I had to Live boot into the new install and then install a boot sector recovery tool to install the boot loader. I opted to have it installed on every single partition. Downloaded updated graphics drivers and rebooted and it works now.
    – Randnum
    Jul 26 '12 at 7:20
  • So basically the boot recovery utility fixed everything and is the solution to this problem/question.
    – Randnum
    Jul 26 '12 at 7:23

had the same problem a couple of days ago. I solved it by first installing Win7 (64).

During my Win7 installation I deleted my "old" Win7 and Ubuntu partitions (both on the same SSD) created during an earlier installation of Ubuntu and recreated them again by using the "Drive options (advanced)" option in the "Where do you want to install Windows?" dialog.

That solved my "cannot install to GPT partition type" problem.

Win7 installed fine and worked. So far so good ... but now the Ubuntu installation was claiming that my SSD wasn't partitioned at all.

I aborted the Ubuntu installation and checked if my Win7 installation was still working. And yes, it still worked.

It turned out that my SSD now had a MBR and a GPT. So the "old" GPT wasn't deleted during my Win7 installation. And the Ubuntu installation wasn't interested in the MBR as long as there was a GPT.

Luckily i found this site.

With the help of a Ubuntu Live DVD I removed the GPT from my SSD with gdisk (as described in the above mentioned site) and restarted the Ubuntu installation.

Now everything is working just fine ... finally!


Ubuntu may be defaulting to gpt if your disks are greater than or equal to 2gb. I had a similar experience (of ubuntu using gpt, but bios couldn't boot it) before and solved it by booting from a USB stick with grub loaded on it. That probably won't help though because you still need to install windows.

I'm now thinking about dual booting and, while I haven't tried this yet, what I'm planning to do is use an efi emulator: http://www.rodsbooks.com/bios2uefi/. If it works perhaps it will solve your problem too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.