I would like to have a Linux live system that contains a Windows xp virtual machine. This would be run from a bootable USB flash drive. My attempts so far have been unsuccessful. I created a Lubuntu 12.04 virtual machine with VMware. I updated and configured it to my needs, and installed Virtualbox. I then created a Windows xp vm with Virtualbox in the Lubuntu vm. I tested everything and everything worked, including USB devices.

I installed Remastersys in the Lubuntu vm, copied the xp vm folder to the /etc/skel folder then created the custom iso with remastersys. I burned the iso and tested it on a laptop. It worked flawlessly. All programs and wireless networking worked. My problem was the xp vm. Virtualbox started fine but would not run the vm. I have the following error:

Result Code: 

    NS_ERROR_FAILURE (0x80004005)




    IVirtualBox {c28be65f-1a8f-43b4-81f1-eb60cb516e66}.

I ran remastersys again changing the permissions on the skel folder to R W for everyone. I also logged into Lubuntu as root and ran remastersys again. Each iso I created worked fine but would not start the xp vm inside. The last attempt virtualbox gave me an access error stating it can not access the virtual disk.

Is what I want to do possible? In theory I don't see why it would not work. Is it a permissions issue? Should I create the iso then add the xp vm after by editing the iso by hand? Using a vm and not real hardware as a build machine a problem? Any ideas? keep any responses in laymens terms. I am still a Linux novice.


Because of iso9660 and FAT32 limitation, remastersys, and genisomage the tool used by it to make the iso files, is limited to a maximum of 4GB files.

The reason to your problem can be the size of the virtual hard drive of the Windows XP system.
The solution to this problem can be to exclude the virtual disk when making the iso and copy it separately to your distribution/portable media.

See http://www.remastersys.com/ for more details about the 4GB limitation.

| improve this answer | |
  • I was able to keep the size of the iso to 3.2 gigs. Still over the FAT32 2 gig limit I formatted the flash drive NTFS. It still worked. I like your idea. casper partition may work.since it's persistent it should hold any changes to the vm. This would be better for update too. I can create new iso without having to include a new vm each time. thanks amotzg – mark Jul 10 '12 at 14:52
  • You're welcome, if it solved your problem please mark it as the answer. thx. – amotzg Jul 10 '12 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.