2

I guess I have exactly the same issue as this poster, but in Excel.

Does anyone have a solution to this?

  • Are you running a routine that pops up an alert or something? – Alfabravo Dec 10 '12 at 17:21
0

Go to File>Options>Customize Ribbon. Then hit reset. Should be all set after that.

| improve this answer | |
  • 3
    Please explain how resetting the ribbon fixes the problem. – DavidPostill Oct 25 '16 at 20:17
  • Didn't work and lost all customization. – jj_ Apr 14 '17 at 1:49
-1

I tried resetting the ribbon and it didn't work.

The quickest solution I could find was closing and reopening the Excel file.

Not going to waste more time on this right now.

| improve this answer | |
  • 1
    Hey downvoter, would you please care explaining the downvote? My answer carries a solution. Maybe it's not the final solution but it's not a discriminant here because the cause of the problem could be buried deep in MS Office code, so unless you expect every answer to include a MS Office reverse engineering session you should accept it as a good when it gives you the best achievable solution, and at the very least not downvote it, unless you shared with us a good reason for that. I guess some people never learn when it's time to say thank you. – jj_ Apr 14 '17 at 1:46
-2

Hit the bottom right "show desktop" in Win 7 and bring back up the windows as you see fit.

| improve this answer | |
  • 1
    Welcome to SuperUser. can you elaborate further on your answer please? also if possible include a screenshot. – Lorenzo Von Matterhorn Sep 23 '13 at 18:44
-2

This happens on MacOS X as well, and while the systems are obviously different, it could be the same reason - the damned ribbon. Try disabling the ribbon in the preferences (if possible - you can do this on the Mac at least), and the behaviour may go away.

| improve this answer | |
  • The Office Ribbon cannot be disabled on the Windows version of Office. – Ramhound Oct 25 '16 at 15:52
  • @Ramhound: It absolutely can be disabled on all versions of office (including those in Windows) from 2007 to 2016 using the VBA macro Application.ExecuteExcel4Macro "Show.ToolBar(""Ribbon"", False)", but also in the preferences in some earlier versions. You can also minimize it on many versions. – Nick Bastin Oct 25 '16 at 16:24
  • There is a difference between disabling the Ribbon and simply not showing it. My comment was simply to illistrate the fact there is no preference option to disable the ribbon bar within Office running on Windows. – Ramhound Oct 25 '16 at 16:28
  • @Ramhound: the preference on the Mac 2010 version does exactly what the VBA macro also does - disables the toolbar. There is no functional meaning to "a difference between disabling the Ribbon and simply not showing it" - the Ribbon performs no computations and takes no actions, it simply takes up screen space. The only thing it does is "be shown", so "not showing" and "disabling" are semantically equivalent. – Nick Bastin Oct 25 '16 at 16:31
-3

Firstly try restarting Excel.

If that doesn't work, try restarting the computer.

Finally, right-click on "Microsoft Excel" in the start bar, and make sure that "Always on top" is deselected.

| improve this answer | |
  • Where exactly is the always on top selection? I can't seem to find it... – c00kiemonster Jul 12 '12 at 0:34
  • Which version of Windows? – Diamond Jul 12 '12 at 9:03
  • Sorry I forgot to mention, I'm running Windows 7 Professional and Excel 2010 32bit. – c00kiemonster Jul 12 '12 at 10:38
  • Did you try the first two steps? – Diamond Jul 12 '12 at 15:01
  • 4
    There is no such thing as always on top. – BroScience Jan 11 '13 at 20:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.