I had a 1TB Western Digital (My book series) 3.5" USB3. One day, the SATA to USB3 converter board was damaged and has not worked since.

I decided to open the cover and use the HDD as an internal HDD.

When I attached the HDD to my PC and booted up in Windows, it asked me which type of ????? I want to use "MBR or GBR" (I dont remember the exact question)

I chose MBR and Windows gave me a 1TB empty Hard drive. I tried to recover with recover my files and some other recovery programs but no success.

  • Some one told me that you should choosed GBR instead of MBR . How can I do that now?
  • Another guy told me that the SATA to USB3 converter board is coded to save data on HDD and you can not use them internally without losing data, and I should find another SATA to USB3 board (exact same).

It is impossible to find because they are not produced any more.

Please help me to find a solution to bring back my data.

UPDATE I have 1TB WD "Mybook" USB 3. the board that convert sata to usb3 was damaged. so when the HDD was in the box computer did not recognize it. I opened the box and remove HDD to use it internal. after connecting to my PC windows showed me one massage that I had two choice MBR or GPT I choosed MBR one and windows gave me 1TB empty new volume. I tried many recovery software to recover my data but no success. I brought it to one expert recovery company and they told me the converter board (SATA to USB3) make some encryption on data and with out that board you cannot recover any thing. so I bought another empty WD box and put the HDD inside but even after that also there is no file. I tried to recover again in this state but no success. so I have some unanswered question.

  • does this converted boards make any password or encryption? if yes how can I solve it?
  • does using many recovery programs affected my data?
  • any suggestion or solution for bring back my data?

I had use recovery programs such as : recover my files , EaseUS data recovery, easy recovery, test disk, Ontrack easy recovery .

Note: when I was using test disk it asked me to choose which partition table I want to use. as it was I choose NTFS, does this made any change on data?

  • I don't understand: In your answer to Alireza Noori you say you got your files back. Did it work or not? If not - what happened? – harrymc Sep 6 '12 at 14:51
  • at first 10 min it found 260 files and i thought it worked but later in next 10hr it remain in that state( only 260 files ) that non of them was belonged to me (all windows files). so i did not get my answer yet – nfarshchi Sep 6 '12 at 15:20
  • I have added an answer below. – harrymc Sep 6 '12 at 16:26

I think you are referring to GPT (GUID Partition Table). It is highly unlikely for your drive to have that since it is only used for drives above 2.5 TB and it cannot be read by computers without EFI. Your friend is mistaken.

The partition table got damadged. Download TestDisk and follow these instructions and see if it finds anything.

  • I am going to try this solution and let you know if any success. – nfarshchi Jul 11 '12 at 10:21
  • 1
    I agree that GPT is unlikely since not everything recognises it and most people/firms go for the most compatible options. However it is NOT just used for hard drives greater then 2.5GB. Is is NEEDED for drives greater than 2.19TB and allowed on smaller drives. Just do not expect XP or NT to recognise a disk with GPT on it. – Hennes Jul 11 '12 at 13:15
  • @hennes so you think the original partition table type of my external HDD was GPT??? – nfarshchi Jul 11 '12 at 14:36
  • No, I think it was MBR. This because MBR is the older of the two formats used on PCs and thus the format which most computers will recognise. I just disagreed with Alaxander that is was only used with drives greater then 2.5TB. – Hennes Jul 11 '12 at 14:48
  • as i told in another comment when windows asked me which I want to choose, I choose MBR. it didn't format my drive because the time between choosing MBR and getting empty drive was a blink. and I had more than 600GB data on drive. so the data should be on the dist but how to recover them? – nfarshchi Jul 11 '12 at 15:07

I had the same problem once. Since my data was so important to me, I used at least 50 programs to recover my files. The best program was Data Recovery Wizard. Give it a try and remember, do not change your hard (e.g. copy files, etc.) because if you put content on your disk it will replace old data.

  • Alireza jan. I am not using that drive but the problem is even after hours of recovery process it can not find any think. – nfarshchi Jul 11 '12 at 10:19
  • Have you tested the software I recommended? Also try to use the amazing HDD Regenerator - Omidvaram moshkelet hal beshe. – Alireza Noori Jul 11 '12 at 10:33
  • mamnoon . i will try and let you know the answer – nfarshchi Jul 11 '12 at 14:45
  • Easeus data recovery are running and show to find 300 file. but still 7 hour left. I thought that "Easy recovery" or "Recover my files" or "O&O recovery" where some of the best in this field. but may be I was wrong. – nfarshchi Jul 11 '12 at 16:01
  • From my experience, I can say that it worked best for me. Let us know the result tomorrow ;) – Alireza Noori Jul 11 '12 at 17:13

Does this converted boards make any password or encryption? If yes, how can I solve it?

A controller could technically add a layer of encryption, but this is highly unlikely. It is a feature rarely found on mechanical external hard drives to begin with, but it also requires user interaction. If the encryption and decryption happened fully automatically, then this would entirely defeat the purpose of the security measure. An attacker could simply attach the drive and read its automatically unlocked contents, without even knowing there was some sort of protection. If this is really what's keeping you from your data, you would have known it.

Does using many recovery programs affect my data?

Any recovery program worth its salt will try to prevent destroying the data in the process of recovering it, but other programs, you or your operating system might not be equally careful. As a rule of thumb, anything you do with the drive will reduce the chances of succesful recovery and it is good practice to start by making a duplicate, then putting the old drive away.

When I was using test disk it asked me to choose which partition table I wanted to use. I choose NTFS, does this make any changes to the data?

Yes, it does. By creating a partition and (quick) formatting it as NTFS, you are making changes to the partition table, the volume boot record and a few more sectors at the beginning of the partition. The first two are hardly important; they contain no data that isn't easily replacable. Assuming you recreated the partition in the same position, which is likely if it covered the entire drive, you may have overwritten some valuable metadata: the master file table. Perhaps it had already been corrupted or erased, but if it were still intact, it would provide a clear list of all files and their locations, making it far easier on recovery programs to retrieve them.

Without this MFT, your best bet at recovering files would be to scan the drive, looking for known headers and footers, hoping fragmentation hasn't torn the file apart, which is far slower, far less reliable and requires a lot more manual effort.

If you merely created the partition and haven't formatted the file system yet, you've probably done no damage.

Any suggestion or solution for bringing back my data?

The OS failing to detect the presence of the master boot record already hints at data loss. You could dig into the raw bits and bytes with a hex editor to see whether anything useful is still there or whether it has been zeroed out completely and attempt a more directed search - in my experience, WinHex is a great tool for this - but this method takes quite a bit of expertise. If you can, I would suggest an accurate recreation of the partition table. Otherwise, delete all the current partitions and create a new one that covers the entire drive, without formatting. After that, throw a whole lot more recovery programs at it and see which one can perform its magic.

  • thank you for your answer. I will try WinHex and let you know the answer. – nfarshchi Sep 6 '12 at 15:25
  • could you help me with giving some advice "how to use WinHex" . I installed it and registered. now after selecting partition I go to Tools> Disk tools > recover by file type. am I right? or I should choose another way? as you said I see throw this partition and it contain some data(it shows me as hex) but there are no a lot of zeros. – nfarshchi Sep 6 '12 at 23:15
  • after 9 hr of recovering it only found 4 .jpg files that they also do not open. – nfarshchi Sep 7 '12 at 6:45
  • Like I said, it requires some expertise. This software is mainly for analysis. If you're unsure what to do with it, it's probably not very useful to you. Nevertheless, the 'Recover by file type' should generally find a whole lot more than four broken jpgs. A few pointers... Make sure you have the right drive/partition opened, make sure all the file types you want to recover are selected and (un)check the search settings, e.g. 'Search in unpartitioned space only'. – Marcks Thomas Sep 8 '12 at 0:49
when I attached this HDD to my PC and windows run it asked me that which type
of ????? I want to use "MBR or GPT"

This is bad.

I checked the WD webpage on their mybook external harddrives. It does not mention any encryption for the drive. This means that transplanting the HDD from the external case to the desktop should have worked.

If windows asks you if you want to use the drive with a MBR or with a GPT then some data on the drive is already missing (or corrupted).

If you have recent backups then now might be a good idea to cleanly format the drive, test it and restore from backups.

Lacking backups try a MBR with a single partition with the NTFS file system (that is the default as WD ships it). Do not format it, just create the filesystem. Then run the recovery programs as suggested in the other posts.

Or, of your data is really important and you do not seem to know all the inns and outs then give the task to someone else.

  • +1 for "give the task to someone else" - specifically a professional data recovery company. – Shinrai Jul 11 '12 at 14:23
  • I had choose MBR and now it is like a 1TB empty partition in mycomputer. but when i use recovery programs it will not find any thing. – nfarshchi Jul 11 '12 at 14:45
  • This advise is a bit late for this drive, but should you ever run into a similar problem, then first make a backup of the drive contents. Do not let windows (or any OS) change anything. First copy the entire drive using DD, cat, cp or a similar tool. – Hennes Jul 11 '12 at 14:54
  • @Hennes : Dear Hennes you helped me a lot on figure what was my real problem. thank you – nfarshchi Jul 11 '12 at 19:29

you could also use an ubuntu live cd and the utility foremost, or scalpel. I have found foremost to be very effective.


It seems that you can physically access your disk, but that the partition tables are in a bad shape.

Here are a few more free products for recovering files from disk :

Recuva (free)
MiniTool Power Data Recovery Free Edition (free to recover 1 GB data)
EaseUS Data Recovery Wizard ($69.95, trial available)

  • 1
    I tried all three but non of them was successful to finding data – nfarshchi Sep 7 '12 at 13:26
  • These are the best recovery products. If they failed, then I think that the problem is that the disk was put in a too-different hardware context, so that the sector-mapping in the new placement is so loused up that none of these products can find the files. Try to return the situation back to before the failure, putting the disk where it was before (after fixing the hardware problem) and retrying all the recovery products you have, but the chances of success are now low. – harrymc Sep 7 '12 at 14:30

Use the TestDisk utility as mentioned by some other user over here. But don't use it in Windows, use it in Linux by getting administrative privileges (using sudo). To get help how to use it in Linux, see the website of TestDisk utility, they have explained the procedure properly by using examples. I got rid of the same problem by using TestDisk 6.13 by using it in Ubuntu (Linux flavour).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.