I know that it sounds too much drastic but something very annoying happened to my new SSD disk.

I bough a Samsung SSD 830 drive for my macbook late-2008. I mounted the new disk with an external case and I formatted it with mac os filesystem. Unfortunaly, I could'n install Mac OS Lion due to a cryptic "an error occurred while preparing the installation". Then, probably I became the dumbest man on the world and I formatted again the disk in NTFS from my Mac in order to mount the disk on a Windows machine and trying to update the disk firmware or whatever. From that moment my disk is considered a read-only drive from all the OSs I tried (Mac OS X, Ubuntu, Windows 7, etc). I don't know what to do because I cannot format my disk again.

I would like to format again my external drive and I hope there is a possibility to do it (in a reasonable time).

UPDATE: I connected the disk to a Windows XP machine via internal SATA and I was able to 'erase' the disk from the Samsung software which told me that the disk was in a frozen state (!). Unfortunately, on the same machine the disk was considered a protected GPT disk and I couldn't format or partition it. Then I moved on a Windows 7 machine and I succeeded in formatting the disk in FAT partition.

  • 1
    Wait, an external case over USB or eSATA? TRIM is not supported over USB. – Lekensteyn Jul 12 '12 at 10:13
  • A case over USB, do I need an eSATA cable? – Matteo De Felice Jul 12 '12 at 10:46
  • 2
    I suggest you to put the SSD in a machine in which you can connect the SATA cable to and retry a firmware upgrade (if not everything is broken). A SSD firmware update over USB is asking for trouble. – Lekensteyn Jul 12 '12 at 10:50
  • Why exactly is TRIM needed in this case? – ephsmith Jul 12 '12 at 12:46
  • 1
    I am not sure what you mean when you say "I formatted ... the disk in NTFS from my Mac". My understanding is that Disk Utility in OS X does not provide any support to format a drive with the NTFS file system. – irrational John Jul 12 '12 at 19:31

Try to connect the drive direcly via SATA to the computer. I have seen many times when a corrupted partition table was confusing the USB case.

|improve this answer|||||
  • If it's a corrupter partition table, there's no tool, as a live CD, something, that could repair it, if we haven't the SATA option (portable pc). – Quidam Jan 31 at 17:57

I formatted again the disk in NTFS from my Mac in order to mount the disk on a Windows machine and trying to update the disk firmware

You do NOT need to format the disk to update the firmware. It merely needs to be properly connected to the (Windows) system you are using to install the update.

Have you tried mounting your disk using using SATA on a Windows system and then updating the firmware for your Samsung 830 SSD as was suggested in one of the comments?

My understanding is that when an SSD fails from having been written too many times, it becomes read-only. But that should definitely not have happened with your drive as it is apparently brand new. You may have gotten a defective drive which may need to be replaced under warranty.

Is there any other error data available which you can include in your question to help better understand what your problem may be? Can you retrieve the SMART data for the drive or run the SMART self-tests? If so, please add this information to your question.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.