0

I need to install the ia32-libs package on my Ubuntu server (version 11.10). When I try to install it via apt-get it says I need this dependency:

The following packages have unmet dependencies.
 ia32-libs : Depends: lib32v4l-0 (>= 0.5.0)
E: Unable to correct problems, you have held broken packages.

When I try and install lib32v4l-0 I get this dependency:

The following packages have unmet dependencies.
 lib32v4l-0 : Depends: libv4l-0 (= 0.8.0-1) but 0.8.5-3ubuntu2 is to be installed
E: Unable to correct problems, you have held broken packages.

What can I do to successfully install lib32v4l-0 and ia32-libs?

EDIT: paste from sudo apt-get upgrade:

chris@ks395362:~/cssserver$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  at console-setup lvm2 ntpdate plymouth
0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
3
  • Can you paste the output from sudo apt-get upgrade? Jul 15, 2012 at 20:42
  • Sure, I've edited it into the post :) Jul 15, 2012 at 20:44
  • 1
    The only other thing I can think of is to run sudo apt-get install -f to repair any broken installs. If that doesn't help, I may have to leave you to wait for a real Ubuntu expert to show up (which I am not). Jul 15, 2012 at 20:49

0

You must log in to answer this question.

Browse other questions tagged .