I have a relatively old computer I wanted to quickly spiff up as part of my SSD addiction. The motherboard is an Abit AS8 and it was already connected to a SATA 7200, which still works fine. I put in the new SSD (Patriot Pyro), fired up an XP install with slipped SATA drivers, formatted and copied everything on the SSD no problems, but then found out the BIOS can't see the SSD to boot! I put the 7200 SATA back in just to make sure (works), and I got the SSD running on a different computer. What could be wrong? Is there some extra protocol the SSD supports that the 7200 doesn't? The motherboard is on "Auto" as far as SATA mode. I tried every possible permutation with the SSD and nothing works. Any thougts?

I have seen this other question: SSD Drive not being recongized in BIOS

This situation is different, because I have other SATA drives working on the computer in question and I have tried my SSD successfully on other computers. The question here is: what is it about my BIOS and SSD causing this failure?

  • How did you copy the content from your HDD to the SSD? Did you also copy the MBR? Latest Firmware for the SD installed? Which SATA-port do you use (connected to which SATA-Chip)? – Robert Jul 16 '12 at 7:49
  • Do you mean the BIOS doesn't identify the SSD at all? Or does it identify it but not boot from it? – David Schwartz Jul 16 '12 at 8:20
  • @David I cant see the SSD in the POST, or in the BIOS. – Mikey Jul 16 '12 at 16:55
  • @Robert Did install from the XP CD which booted and then saw the SSD, it fully installed including MBR and made it to windows splash on totally different hardware, need to check firmware, tried both SATA ports. Will try to find the chip. – Mikey Jul 16 '12 at 16:55

The BIOS setting for the SSD mostly likely needs to be set for AHCI. If your BIOS does not support AHCI, you may be able to flash the BIOS to a newer version that supports it, however this is unlikely if the motherboard is really old.

Your only other option would be to get a PCI/PCIe SATA add on card.

| improve this answer | |
  • Pretty sure this AHCI thing is the issue. My BIOS (Intel 865) does not support that. – Mikey Jul 16 '12 at 16:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.