7

I am trying to get a symlink working over a network drive.

I have already tried suggestions on questions already asked, such as running as administrator and checking if the directory already exists. Unfortunately it still gives me the following error:

C:\Windows\system32>mklink /d \\myserver\SomeDir\SomeLink \\myserver\SomeOtherDir\MyDir
Access is denied.

Where SomeLink is the link I am attempting to create and Mydir is the directory I am trying to create it on.

Any ideas how I could get this working? The local machine is running windows 7 and the remote machine is running windows server 2008 R2 standard.

11

Robert is wrong. Remotely mklink DOES work. Here is the solution:

Run command prompt as admin and then run this command:

fsutil behavior query SymlinkEvaluation

If you see message "Remote to remote symbolic links are disabled.", then run this command:

fsutil behavior set SymlinkEvaluation R2R:1

After that, you can run

mklink /d \\myserver\SomeDir\SomeLink \\myserver\SomeOtherDir\MyDir

  • Well, ill be damned, it works. Good first answer, welcome to SuperUser! I hope your future answers are as informative as this one. (FYI to people using this, the network link worked fine for me, but I had another person connect to the remote machine from his machine, they could see the link but got a permissions error when they tried to follow it) – Scott Chamberlain Aug 28 '13 at 20:15
0

By default mklink only affects the local computer. Remote manipulations are not possible in that case.

Therefore if you want to add a symbolic directory link on a remote machine try to execute mklink.exe via PsExec on the remote server, then using the local directory path of the two directories.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.