4

I have a large Visio diagram that spans multiple pages according to the print area. However, I would like to save this to a PDF file and have it only display as a single page in the PDF. My users should then be able to navigate around the image and zoom in where necessary. I cannot seem to find any options for it and all my attempts at saving to a PDF result in multiple pages within the PDF.

Is what I'm looking to do possible?

  • 1
    You have to change the "paper" size of the document. – user3463 Jul 16 '12 at 21:57
1

For some reason I only have Visio 2007 installed at present. I know you can do this from the bar in 2010.

If you bring up the Page Setup dialog you will see two tabs containing page sizes. The first is the printer page size and the second is the drawing page size.

On the Print Setup tab, change the paper size to the one you want to print on, for your purposes, make it as large as you can - A0 perhaps. Then set the "Print Zoom" to "Fit to" 1x1

When you print preview you should see that everything is on one page. Now print to PDF - you may need to up the resolution of the PDF driver though depending on how good your PDF to Print driver is. Otherwise, when zooming in, some elements may become pixilated because they have been turned into bitmaps. Though as long as you have chosen a suitably large "paper" size, you should be OK. You may need to experiment a little.

The other issue you may get is PC's running low on memory when trying to view the resulting PDF. If parts of the PDF turn black or blank when viewing, this is the issue.

  • The problem still persists. Even if you print with PDF print driver - you cannot get Visio page numbering. It's still thinking it's ONE page. – Paktas Feb 22 '18 at 20:55
  • That was not the question. If you have a different issue, please ask a separate question. The whole point of my answer was that the OP asked to get the diagram on a single "page" in a PDF that could then be moved around and zoomed in on. – Julian Knight Feb 26 '18 at 14:09
1

I looked at every setting as I had the same problem. This is what I found resolved the issue:

  1. Open Adobe Acrobat Reader and go to Edit/Preferences and change the pixel/inch ratio back to the standard.
  2. In Visio, go to Design tab, Size, and then More Page Sizes, and change the page size to Custom (your needed size.) (This opens Page Setup.)
  3. The printer paper size I could not change, but it didn't affect it.

The first option is what took me an hour to figure out. Hope this helps save people time.

  • Interesting, the same as this link but you do not give it credit or say this is where you got this information from: forums.adobe.com/thread/1422028 – Pimp Juice IT May 19 '16 at 12:35
  • This does not solve the issue for Visio thinking that it's printing ONE page (instead of Multiple). – Paktas Feb 22 '18 at 20:57
1

The way that I do it is to have the area you want to print on the screen, use the Adobe PDF printer, then choose "Print Current View" and check the "Fit the current view to a single sheet" box.Where the options are in Visio 2016

  • Page numbering does not work and you'd need to cutout every part separately. Nonsense... – Paktas Feb 22 '18 at 20:58
0

Another simple solution to check: Windows display scale settings.

I just found out, because I couldn't find the settings in Acrobat Reader DC mentioned by BGTwrk, that for me the issue was having display scale settings in windows set to 125% on a high resolution display.

My specs for the problem and solution:

  1. Windows 10 Pro x64
  2. Microsoft Visio 2016 Professional
  3. Sheetsize ~840*1100 mm (A0)
  4. "only" Adobe Acrobat Reader DC
  5. Display scale set to 125%

Save to PDF always cropped on the right and bottom.

Solution:

  1. Set display scale back to 100%
  2. Log out from Windows and log in again
  3. Be happy about a correctly saved PDF file
0

I tried all the above to no avail. In the end, I didn't use File: Export to PDF at all. I used Print: Microsoft Print to PDF. I had to go into page setup:Print Setup:Print Zoom to Fit to 1 Sheet Across, 1 sheet down on each sheet of the Visio file first.

Came out beautifully. But I spent a frustrating couple of hours getting there. I forget where I saw that suggestion, but you do need to set the Print Zoom first.

0

Ok so this is way too late, but in the newer versions, forget the "Print" option. Just "Save As", and then in the dialogue box to change the file type, select PDF. It creates one large PDF that matches whatever size your drawing is on the screen. No specified page sizes to worry about.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.