I'm fighting with .DS_Store files when copying folders across my network using Finder, from an OS X Lion machine to OS X Mountain Lion, both on late-2009 27" iMacs.

When I drag a folder from Lion to the shared drive on ML, I get this error message:

The operation can't be completed because an item with the name ".DS_Store" already exists.

The problem existed before the Mountain Lion upgrade, but I'm pointing it out for the sake of record. I was using Asepsis to fix it on Lion, but that hasn't worked since 10.7.4.

I have done a fair bit of searching for a way to work around this problem.

  • Creating the folder manually, and then dragging the files seems to work just fine.
  • Using Terminal.app and cp works just fine (as does rsync and all the other utilities).

I've disabled the creation of .DS_Store files on network devices, on the Lion machine, using

defaults write com.apple.desktopservices DSDontWriteNetworkStores true

and I have tried to remove .DS_Store files from the folder before copying, which does work. But as soon as the folder is opened, a .DS_Store file is created, and the problem persists.

I suspect this is a permissions issue, because I've noticed when merging folders locally (using Finder specifically) that .DS_Store doesn't like to be overwritten.

The user of the Lion machine is not technical, and would prefer it to "just work" like Steve intended. Why did it work in the old days, and what can I do to make it work now, without the workarounds I've listed?


It appears that Asepsis was updated to 1.3 while I wasn't looking, which fixed the problem in 10.7.4. I've installed it on the Lion machine, and it seems to have resolved the problem.

I'd prefer not to use a third-party plugin for Spouse A, but I think Asepsis will solve more problems than it creates.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy