I'm on my Windows 7 computer and want to set up .NET Framework. However it's asking for an administrator password but I have no idea what it can be. I really need the .NET Framework. I hope there's a portable version but I'm worried there isn't.

Does anyone know how to run the setup without knowing the administrator password?

Tried programs and trick:

  • Universal Extractor - it's only extracted not installed but they said it could install
  • cmd - tried all commands
  • Some password hack/viewer - none of them is working
  • Searched the whole computer for some passwords or things that can help
  • It is your own computer and you don't know the administrator password? How do you install / modify anything? – Joe Taylor Jul 17 '12 at 15:44
  • Also there is no portable .Net Framework. You may be able to get aruond this by installing .Net Framework through Windows Updates if your administrator lets you do this. – Joe Taylor Jul 17 '12 at 15:44

To install .NET you must have administrator privileges. Perhaps your administrator account is just disabled.

  1. Try to boot into Safe Mode (F8 at startup) - the administrator account gets enabled there
  2. Login as Administrator (maybe no password)
  3. Go to users and give your account administrator privileges (add to Administrators group) or activate the Administrator user permanently

Login as a user who is a member of group Administrators and you will not be asked for a password in the UAC prompt. Instead, you will simply have to click Yes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.