I have a freshly unboxed Lenovo Ideacentre Q180, it ships with FreeDos so I'm trying to install Linux (XBMCbuntu ideally, but any distro will do for now).

I have used UNetbootin to make a bootable USB pen (I've tried it with isos of various distros, including a 32-bit Win7 iso) but when I boot from USB the machine goes straight from BIOS to hanging with a blinking cursor on an otherwise blank screen, or with occasional flashes of a mouse pointer, depending on the iso used.

I've installed Linux from a USB pen dozens of times with various distros on to various hardware.

The machine I'm using is easily capable of running linux:

  • Intel Atom D2700 2.13GHz Processor
  • 4GB RAM
  • 500GB HDD
  • AMD Radeon 6450 Video card
  • No optical drive

Looking at the BIOS settings, nothing seems clearly wrong, I've tried various boot order settings, and hitting F12 on boot allows me to choose my USB key specifically. The SATA HDD section only has the options of 'IDE Mode' or 'Disabled', I've tried both settings.

So, what else could I check? Or which approach could I take to get more info about the problem?


  • Have you tried different USB pens? Jul 17, 2012 at 21:29
  • Now I have, instant success. I'd totally forgotten to consider it. Jul 17, 2012 at 23:26

3 Answers 3


You should let Unetbootin download the ISO it wants. Some newer distros have a thing where the new ISO doesn't agree with what Unetbootin expects. This causes throwing the ISO on to USB to fail.

It's at least one thing to try...

Also, generally windows doesn't run properly from USB. There are workarounds, but they are quite involved.


Try booting from different USB ports, it has usb2 (on the back) and usb3 (on the front).

With linux... was it x64? I have read that Ubuntu 10.04 x64 will work but not 12.04 x64... you need to install Ubuntu 12.04 32bit.

You may want to try PenDriveLinux instead of Unetbootin... Unetbootin has always been hit or miss with usb thumb drives for me.


I had a blinking cursor when trying to boot Ubuntu 13.10 off a USB flash drive I created using Unetbootin. No flashing screen or mouse pointer. As strange as it sounds, doing a full (not "quick") format of the USB drive before running Unetbootin fixed the problem. I think I formatted as FAT32 (the device default) in case that matters.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .