I am watching videos streamed from NetFlix using Chrome and Windows 7 over a Wi-Fi connection to a Belkin N150 (F6D4230-4) router. NetFlix appears to completely flood my internet connection, and other devices on the network can't even successfully look up host names via DNS while it is running. This is true for an iPad 2 and a laptop running Linux connected to the router via a wire or Wi-Fi. On the latter, I don't get DNS responses whether I use the router as DNS server, or if I try something like or I do get ping responses, though.

I tried decreasing the NetFlix quality settings to "Good quality (up to 0.3 GB/hour)" but this did not help much. The router's web configuration interface does not appear to have any QoS settings.

Is there something else I can change so that I can view streaming videos from NetFlix while still being able to use the Internet from other computers on the network?

  • What kind of Internet connection is this? (DSL? Cable?) And what is the advertised download speed? What speeds do you get when you go to speed testing sites? – David Schwartz Jul 18 '12 at 2:43
  • This is cable. Speedtest.net says 24.77 Mbps on a Tuesday evening in a residential neighborhood. – Michael Hoffman Jul 18 '12 at 2:52
  • 1
    That's good enough that there's no reason you should have these kinds of problems. Your router (assuming it's hardware version 2 and firmware version 3) has a measured WAN-to-LAN performance limit of 50Mbps, so it shouldn't be a router CPU issue. – David Schwartz Jul 18 '12 at 2:57

I don't have enough reputation to comment, so I'll ask some questions here along with some suggestions...

What type of connection do you have, and what speed is it rated for? Does Netflix buffer (load) frequently?

Some generic suggestions without knowing these things:

  • If you get buffering fairly regularly, odds are you either have too low of a connection (a 1.5Mbps DSL line BARELY runs Netflix), or you're saturating your connection with too much stuff at once (do you have any large downloads running?)
  • Your router could have trouble keeping up with the traffic, due to faulty firmware, lack of resources, etc. I'm not too familiar with Belkin routers, so I'm not much help there
  • If you're on a cable line, it's possible you adding a Netflix stream is just enough to saturate the "neighborhood" pipe (bandwidth is shared between a group of neighbors, so 5 people with 20Mbps lines might be sharing a 50Mbps pipe)

As for QoS for Netflix, you're probably out of luck. From my research for a similar problem (I couldn't use the internet while watching Netflix or it would start buffering whatever I was watching very frequently, due to a small DSL line), Netflix streams via HTTP. Granted, I never actually tried sniffing the traffic, but everything I found online pointed to that.

Finally, a "related" question got an answer related to a bug in dnsmasq used in DD-WRT and other custom firmwares, but the OP never marked it as solved. The OP in that question WAS using a similar router (A Belkin N150, although no model was listed), so I'm thinking a firmware/hardware bug may be at the root of it. You should look at updating your router's firmware, or possibly flashing a custom one if one is available (I personally use DD-WRT). If you have the ability to try another router, try that if an updated/replacement firmware doesn't help. If that's not an option, you can find fairly cheap replacements on Amazon or Newegg (the Asus RT-N10+ is currently $25 on Amazon, and supports DD-WRT...that's the one I'm currently using).


Setting Quality of Service on the router would be the easiest, most reliable way to handle this.

The N150 (F6D4230-4) may or may not support a QoS function. It may depend on the version (1/2/3). You would have to check the manual or configuration page for IntelliStream to be certain.

If your router does support IntelliStream, then you can set it up to prioritize DNS, HTTP, etc. or conversely lower the priority of Netflix.

Unfortunately the F6D4230-4 does not support DD-WRT because its Flash memory is too small, so if it doesn't have IntelliStream, then you may want to consider getting a new router that does have QoS. Decent routers can be had for next to nothing today (especially if you get a used one from online classifieds like eBay Classifieds or Kijiji).

  • I updated the firmware to version 2.00.08 but there does not appear to be "Media Features," "IntelliStream," or "QoS" on the configuration menu. – Michael Hoffman Jul 18 '12 at 3:02
  • When you say you updated the firmware to version 2, do you mean for version 2? That is, is your router version 2 (check the label on the bottom)? You must use the firmware for your specific revision because using the wrong one may ruin it. – Synetech Jul 18 '12 at 3:30
  • It was either 2.00.04 or 2.00.05 before. – Michael Hoffman Jul 18 '12 at 3:45

Had the same problem. 25 MB download speed but when watching Netflix 4K in a smart TV all computers at home cannot open any web page. Change DNS for the PC / laptop internet connection and problem is solved. Is a matter of your Internet Provider DNS been saturated not bandwith

  • Sounds weird to me, as I'd not expect Netflix to perform a lot of DNS queries. But since it worked for you, maybe it helps someone else too. – Arjan Jun 12 '16 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.