As the title says and you can see in the image: The monitor is connected through HDMI to my laptop. My screen settings are as you can see on the image, full res on both displays (1080p on external, 1366x768 on laptop) and "expand desktop to both displays". I have full 1080p res on the external display, but it gets scaled down on the monitor and there is an ugly black margin (marked red in the included picture). It works without this problem on linux on the same machine. Laptop is a Sony Vaio VGN-NW21SF, with a ATI Mobility™ Radeon® HD 4570.

Thanks in advance.

My screen setup. Ugly black margin on external display

  • Can you confirm, all drivers and chipset is up to date on W7? – Dave Jul 18 '12 at 12:03
  • yeah, there is no newer driver I could install. Funny enough, I tried it out now with VGA, and using VGA it works as expected. But i'd still prefer HDMI because of audio (speakes on my monitor) and better bild quality... – joni Jul 18 '12 at 12:05
  • Must be in the driver properties. Look at ATI in programs and see what options you have. EDIT - as per Doubtme suggestion – Dave Jul 18 '12 at 12:07
  • OK, on the screen you have shwoing in your post, click on Advanced. Click on a tab called Media Acelerator driver. Then properties - in this, I have a 'border' option I can turn off or on? – Dave Jul 18 '12 at 12:11
  • Looks like the graphic driver has "underscan" activated on the HDMI monitor. – Robert Jul 18 '12 at 12:26

OK, sadly, the answer is you need to have the catalyst installed (or so I think).

Details here to fix it: http://www.tomshardware.co.uk/forum/285358-15-image-fill-screen

Snippet from site:

goto CCC>graphics>desktop and displays>please select a display>click on black triangle>configure>attributes>select scale image to full panel size

  • 1
    finally found it. CCC->Desktops and Displays->Right click on HDMI Monitor->Configure->Scaling Options tab->Move slider to 0% (Overscan). Ati should win the bad UX contest for creating CCC :P – joni Jul 18 '12 at 12:51

I would imagine this probably has something to do with the ATI manager or driver manager. I would take a peek in those and if you don't have it then get it.

  • already tried this, but the newest version of catalyst doesn't install ("no compatible video hardware") and the newest version (2009...) I can get from sony driver download page doesn't solve the problem. – joni Jul 18 '12 at 12:07
  • Never experienced this before HDMI only. Try hooking it up to anything else that has an HDMI input like a tv to see if it does the same thing. Other then that (its working with VGA, Linux just fine)...when you press the windows key + P try hitting extend – Doubtme Jul 18 '12 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.