I’m running Windows 7 with a wired connection to my Verizon FIOS router. My download speeds are usually around 80 Mbps, but my upload speeds are lucky to break 1.0 Mbps. This is a new problem, although I haven’t changed anything about my set up. We did, however, suffer a bad storm and power outage before all of this happened.

My wireless network—plugged into the same router—is fine. My laptop connected via ethernet to the router is fine. (Upload speed is usually around 30.0 Mbps.) So it’s only on my desktop that this problem is occurring.

I’ve tried everything I can think of or find to fix it, with no success.

Any thoughts?

  • 4
    Can you explain some of the things you did to try to fix it? That way we don't just repeat every thing you've already tried.
    – imtheman
    Commented Jul 18, 2012 at 20:25
  • Replaced the ethernet cable. Ran the FIOS TCP/IP optimizer. Powercycled everything. Cleared the internet cache and temp Windows files. Tried different browsers. I even tried hooking a wireless adapter into the desktop, with the same results. Commented Jul 18, 2012 at 20:41
  • 3
    Have you tried different ethernet ports on your router? (I don't think that's the problem, but I guess it doesn't hurt to try) What NIC are you using? If onboard NIC have you tried adding a PCIe NIC?
    – imtheman
    Commented Jul 18, 2012 at 20:50
  • If you suspect damaged hardware you should see if the problem also occurs when you use another OS, e.g. a Linux live system like Knoppix. Commented Jul 18, 2012 at 20:52
  • I've tired different ethernet ports on the router. (And the router's brand new -- Verizon came out and changed it.) Commented Jul 18, 2012 at 21:10

8 Answers 8


Since you don't have the problem on your wireless router connected to the same router, and you changed the ethernet cable, I think you're right in assuming that the problem is inside your machine. By chance did you try, if possible, a different ethernet port on your router (assuming it has more than 1).

The fact that you tried a wireless adapter on the desktop makes me doubt it is a problem with the ethernet card, however I still want you to try and removing the ethernet card drivers and let Windows automatically find and install new ones.

After that, could you by chance try booting into another OS like Ubuntu from a Live CD and see if you still have the same upload issue from there? That way we can get closer to knowing if it is a software or a hardware problem.

  • I uninstalled the etnernet card and removed the drivers. Rebooted and Windows found and installed it automatically. Ran the speed test and got a good result. Ran it again and got crap. (Something similar happened previously -- one good test, then nothing -- although not connected to the ethernet drivers.) I've never done anything with Ubuntu (etc.) but I can try to figure it out. Commented Jul 18, 2012 at 21:23
  • Wait so, it worked fine the first time you ran speed test but not the second time? Keep in mind that speed test results will also depend on the server chosen.
    – MetaGuru
    Commented Jul 18, 2012 at 21:25
  • I have twice now gotten a decent speed after some type of change and a fresh reboot. But the speed is never duplicated, either by testing the same server or different ones. Commented Jul 18, 2012 at 22:30
  • I booted with Ubuntu from a USB and everything worked fine. Good, repeatable speed tests. No slow down. But when I rebooted Windows, I had all kinds of trouble getting it loaded. It kept hanging on Startup, crashing, etc. When I finally got it booted up, I ran a speedtest. Great results. Ran the test again, same server, and the slow upload was back. So it seems Windows is screwed up somehow. But with really odd results. Commented Jul 19, 2012 at 0:01
  • @DavidMontgomery Curious indeed... are you able to see anything happening in the Windows Event Viewer around the time of the power outage, or something new now showing up after the power outage? Worst case scenario, you might have to make some backups of your data and do a fresh install of Windows...
    – MetaGuru
    Commented Jul 19, 2012 at 14:39

I had the same problem and this helped me. Reposting the answer:

The answer turned out to be the Large Send Offload (IPv4) setting on my NIC. It was enabled by default. When I disabled it my work upload speed jumped to 12+ Mbps. It appears that if the infrastructure (e.g. routers, switches) don't support this option the transmits become "bursty" and slow down. My home router (an Apple Airport Extreme) apparently does support this option.

To disable, go to Start->Control Panel->Device Manager->Network adapters->[your LAN adapter name], right-click then select Properties->Click Configure button. On the Advanced tab, find property Large Send Offload (IPv4) and change its value to Disabled then click OK.

  • Right click My computer and go to Properties.
  • Click Devise Manager, then go to Network adapters.
  • Click on that and then Right click on your nic card and go to properties.
  • Once in there click the Advanced tab.
  • Under the "Property" tab in advanced settings tab, click on "Large Send Offload (IP4V)"
  • Switch the "Value" to Disable.

You can try to set the network adapter on the desktop to 'hard coded full duplex', instead of 'auto' to fix the issue.


I had same problem, after I uninstalled CiscoVPN and NordVPN, the problem was solved. I don't know the reason, I haven't used these VPN just existed as ethernet adapters in device manager.


in my case problem was ANOD Network Security Filter ; turn off and upload speed go good; Redirecting (https://answers.microsoft.com/en-us/windows/forum/all/what-is-anod-network-security-filter-driver/aea0e877-39c5-4200-a6aa-048696c49b48)

  • 1
    Welcome to SuperUser. Please do not post link only answers as the linked site might change, rendering your answer useless. Instead please quote the important parts and provide the link for reference only. Commented Feb 7, 2023 at 15:57

If this is a home type connection, it is normal that the download speed is much, much higher than upload (home use is send a short HTTP request, pull down a huge bank page or a movie).

  • Verizon FIOS is symmetrical.
    – Andy
    Commented Oct 14, 2015 at 1:47

Try looking for the most updated version for the driver of your ethernet card via manufacturer's website. Windows would only automatically install the driver it previously had in system32 and that may have been corrupted from the power outage.

  • 1
    This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post.
    – Ramhound
    Commented Sep 10, 2015 at 11:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .