I wanted to uninstall VMware Workstation v8.04 from my Windows 7 64-bit machine. I could not do that from Control Panel. I received "The MSI failed" error like this:

I then followed this link to remove VMware manually:

Now whenever I go to Control Panel > Programs and Features, there is no VMware in the list. However when I want to install an older version of VMware (v8.02), the newer version is installed on the system with a uninstall button. When I click on this button I receive this error:

Bad Arguments for :C\ProgramData\VMware\VMware/Workstation\Uninstaller\uninstall.exe

I tried to install v8.04 again, but I got the same error. I also cleaned up the uninstall with Revo Uninstaller.

Any ideas how I can fix it?

migrated from stackoverflow.com Jul 18 '12 at 22:19

This question came from our site for professional and enthusiast programmers.

  • 1
    Do you have a question about programming? – Steve Jul 18 '12 at 22:08

I found the answer at the end of this tutorial:

VMware KB: Cleaning up after an incomplete deinstallation on a Windows host

Two ZIP files have been attached to this article, which you need to run. They clean all registry entries related to VMware from Windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.