I had a working system that booted xp and linux just fine from grub2. I changed systemboards to one that has uefi and now xp hangs unless i use f11 and boot directly to the drive with xp in the mbr etc. I have multiple drives I have several versions of linux and no matter which version of grub on either linux version it hangs when I choose xp. I tried to install grub.97 to try the original and I believe i got it changed out and it did not work either.

Any thoughts on getting a version of grub to work with uefi would be appriciated. I plan to try setting the legacy bios boot option in uefi this weekend to see if i can get it to play properly with this board but would much rather figure out why it broke in the first place. I know there is a patch out there to make xp 4k sector complaint and wonder if that might be of help but will have to test this weekend. I installed xp by deleting the partition and had xp create a ntfs partition in the empty space so the partition information should not be a problem. that 2ndary drive was the only drive in the system at the time so no cross polution from other drives should be present.

I had seen 1 post in ubuntu about it where a person corrected the mbr/partition for a user and got it to work but doubt that will work for me. xp is on partition sda1 and sdc5 sdc5 is a ghost to a 40gb partition. I have tried booting both via grub2/uefi no luck. before it would boot sdc5 from grub no issues.

  • Are you using native UEFI booting (i.e. with an EFI system partition and a grubx64.efi file)? Windows XP doesn't support that. Using legacy BIOS emulation booting (i.e. GRUB in the MBR) should work, but I don't think you can boot GRUB using EFI and then have it chain-load an OS that expects a legacy BIOS. – Wyzard --Stop Harming Monica-- Jul 19 '12 at 4:14
  • I have tried several ways. the grub2 that was installed pre uefi systemboard just worked. I tried installing the efi grubs 1 at a time to see if it made a difference no change. I will be setting the bios to legacy next time i boot probably this weekend and see if that fixes it. it gets me though even with uefi bios enabled if i boot straight to the xp hdd & loader it works fine just grub uefi and xp doesnt play right :/ – Kendrick Jul 24 '12 at 23:48
  • My bios does not have a specific legacy mode like some do. – Kendrick Aug 18 '12 at 4:34

From your comment that your EFI BIOS has no "legacy mode" setting, I suspect it's automatically looking for an EFI bootloader, and then a legacy bootloader if there's no EFI one. It's very unlikely that it actually doesn't support legacy booting.

Windows XP only supports legacy booting. The EFI version of GRUB can't perform a legacy boot, so you'll have to use the legacy-boot version of GRUB. (Note that this doesn't mean using an old version of GRUB; GRUB 2 comes in both legacy and EFI boot flavors.)

If you've installed a legacy-boot GRUB and it's still failing to load XP, it may be that your system is still booting the EFI GRUB and never noticing the legacy one. Since you're not going to be using EFI booting at all, you should delete your EFI system partition — this is where EFI boot applications like GRUB get installed — to ensure that your system finds no EFI bootloaders and falls back to legacy boot instead.

Newer versions of Windows support EFI booting, so you might want to consider just upgrading. You'll need to install the 64-bit build, and ensure that the install DVD is booted in EFI mode (which it sounds like your system might do automatically).

  • the drives were straight from a legacy system, I don't know that there is a efi grub partition on there. I thought I had installed a non efi grub but will have to check again. My ubuntu is a 32bit version as I had some issues with 10.4 x64 application wise. I may try installing server 2k3 or xp64 and see if that fixes it but haven't had time to do so yet. 2k3 is the highest I will be going as I don't plan to buy another copy of windows. The aged versions of windows I have now should suffice till wine works well enough. this almost feals like a grub bug as others have had this to. – Kendrick Aug 19 '12 at 5:37
  • XP and 2k3 do not support EFI, not even the 64-bit versions. Only Vista and newer do. – Wyzard --Stop Harming Monica-- Aug 19 '12 at 6:49
  • Ends up it was a bios glitch. I finally updated to the latest and it works from grub 2 2.00.6 beta that I had installed from fedora. I havent had a chance to update the ubuntu grub and such but bios 1.9 that my board came with also had an odd issue where the mouse would not work in it. so go figure. – Kendrick Aug 22 '12 at 3:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.