5

I had a partition with Windows 8 Release Preview, Windows' System Reserved partition and the empty space of the beginning of disk. I moved two partitions to the beginning of disk using Ubuntu Live CD and GParted.

After that, the Windows Loader didn't boot and throw an error about missing files. I fixed it using the commands:

bootsect /nt60 sys /force /mbr
bootrec /rebuildbcd
bootrec /fixboot
bootrec /fixmbr

When I used "Automatic repair" option from "Advanced boot" menu, it throw an error like:

Windows can't fix your boot problems. For more information see file C:\Windows\System32\LogFiles\Srt\SrtTrail.txt

In this file I found a description of the system repair actions and at the end of file:

Boot status indicates that the OS booted successfully.

Now, when I use the Advanced boot menu from Windows 8 (PC settings -> General -> Advanced startup) I receive an error:

Restart your PC to try again. It looks like something didn't load correctly. Restarting might fix the problem. If this happens more than once, you might also be able to find help by searching online for the specific error code. Erorr code: 0x8007090.

0x80070490 is the error code ERROR_NOT_FOUND.

What are the missing boot files and how can I restore them?

List of files in System Reserved Partition:

B:\bootmgr
B:\BOOTNXT
B:\Boot\BCD
B:\Boot\BCD.LOG
B:\Boot\BCD.LOG1
B:\Boot\BCD.LOG2
B:\Boot\BOOTSTAT.DAT
B:\Boot\Fonts
B:\Boot\memtest.exe
B:\Boot\qps-ploc
B:\Boot\Resources
B:\Boot\Resources\bootres.dll

and many *.mui and *.ttf files.

4
bcdboot c:\Windows /s c: /l en-us

(this one works like a charm!)

  • 2
    i restarted windows 9 times, all succesful boot ;) – infocorp Nov 21 '12 at 3:15
  • Do we need to have the Windows DVD in at the time of running this? – James Dec 28 '13 at 15:24
1
  1. You must check that SystemReserved is set as active partition.
  2. bootsect /nt60 all /force /mbr
  3. bcdboot c:\windows - (assuming c:\windows is where Windows 8 is installed. If not change c: to correct drive_letter.)
  • 1. My System Reserved partition is active. 2. I already did it. 3. And it too. – Aleksandr Vishnyakov Jul 21 '12 at 5:45
1

Srttrail.exe double boot failure followed by automatic repairs.

I did a restore if you can get that far.

Then do a custom install instead of express. Turn off updates on install. Allow the computer to boot and create a restore point. Then try updates.

This worked for me and i tried everything else I could think of.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.