7

So, I just bought a new laptop, installed Google Chrome, and discovered to my dismay that when I try to do what I normally do to perform a search, Google Chrome is acting wonky.

To normally search on every other computer I use, I start typing google in the adress bar, when I get to goo (usually), I'll hit TAB to enter "site search mode". Chrome is being a jerk and trying to take me to a page that is in my history.

I've tried clearing my history to see if that would fix it, but it still won't seem to work.

So, what can I do to make "search in site" work for Google (when it works by default for every other installation of Chrome)?

2
7

Go to chrome://chrome/settings/ then Manage Search Engines and in order for feature to work it must be added to the list of search engines. Chrome typically adds it automatically once you visit the site though.

3
  • 1
    Tab search in Chrome stopped working for a site that had previously worked. I removed the site from the list and visited it again. Works again. I assume the site changed and chrome was using an old URL or something. – Samuel Nov 18 '13 at 22:59
  • For me tab moves focus from address bar. – jarno Dec 5 '16 at 11:32
  • Thesarus.com stopped working and neither adding it manually nor visiting the website did not solve the problem. – arthur.sw Sep 20 '18 at 9:33
2

In Chrome, visit chrome://settings/searchEngines
...You will see a list of all the tab-activated search engines, which Chrome has collected.

I will assume the search engine you want is NOT listed. If your engine IS listed [a problem I have NOT encountered], it may help to delete it, and re-add it using the following instructions:

Click [Add]

Search Engine: <Any friendly name you like>
Keyword      : <What you type in the URL bar to activate the search feature>
URL          : <The search URL with "%s" where your search words must appear>

Example ...I recently enabled the Youtube dark theme, which broke the Youtube "tab search" in Chrome:

Search Engine: Youtube
Keyword      : youtube
URL          : https://www.youtube.com/results?search_query=%s

Click [Add] (again)

If you do not know what the search URL should look like: Go to the website in question, perform a search, and look at what ends up in the URL bar ...Your text will be "URL Encoded", EG. spaces will be replaced by +'s (etc) - do not worry about that, the URL encoding will be done by Chrome's search engine for you :)

Example.
Go to Amazon and perform a search for "eneloop AA" which (for me) generates this URL:
https://www.amazon.com/s?k=eneloop+AA&ref=nb_sb_noss_1
...You might notice that if you remove the "&ref..." from the end, the search still works
https://www.amazon.com/s?k=eneloop+AA
...So our Search engine URL could be:
https://www.amazon.com/s?k=%s

1
  • Thanks, it is working for me. – Ramil Aliyev Feb 13 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.