My brother bought a HP V210W 16GB usb stick. It wasn't recognized by his MBP 13" (2011, 2.7GHz i7, 4GB 1333MHz DDR3) running OS X 10.6.8. He then tried the stick on his Win7 PC which recognized it just fine, and formatted the stick as FAT32. It still didn't work on his MBP: didn't mount, wasn't recognized in Finder, didn't show up in Disk Utility or System Profiler.

On my MBP 13" (2009, 2.53GHz Core2Duo, 4GB 1067MHz DDR3) running OS X 10.5.8 it works fine: it gets recognized and I can access the files on it. Erased everything using Disk Utility, re-formatted as FAT32. Still doesn't work on his MBP.

Is this an issue caused by hardware (either Mac or USB stick), formatting/partitioning (FAT32), operating system (Snow Leopard vs Leopard) or something entirely different?

Thanks for your response in advance.

  • Have you tried a different USB stick in his MBP? A printer? Some other USB device? – user3463 Jul 21 '12 at 22:15

My HPv210w USB stick worked fine on my MacBook Pro with Mountain Lion for a while until recently it wouldn't show up in Finder. Strangely I was able to move files to it.

I tried shutting down then logging on as 'Guest User'.

Hey presto! there was the HP stick with all its files accessible.

Next stage was to back up the stick to my external hard drive. Then it was just a case of opening Disc Utilities, repairing and reformatting the stick and shutting down.

When I restarted in normal passworded mode the stick was showing again in Finder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.