3

What is the procedure to install Privoxy on a Centos machine?
I have tried yum install privoxy, however, I get No package privoxy available.

I am unsure if I am supposed to add any additional repos or use an alternative method.

I have done a Google search for an answer but was unable to find a solution.

5

These commands are more easier and manageable

wget http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
rpm -Uvh epel-release-6-8.noarch.rpm
yum install privoxy -y

In future if you want to update

yum update privoxy -y

Ref: http://pkgs.org/centos-6/epel-x86_64/privoxy-3.0.21-3.el6.x86_64.rpm.html

| improve this answer | |
0

Enter these commands:

wget ftp://ftp.pbone.net/mirror/rpm.razorsedge.org/centos-4/RE-test/privoxy-3.0.12-1.el4.re.i386.rpm
sudo rpm -Uvh privoxy-3.0.12-1.el4.re.i386.rpm
sudo service privoxy start

Source: http://www.privoxy.org/user-manual/

| improve this answer | |
  • Shouldn't he be using packages for centos-6 rather than 4? – Journeyman Geek Jul 23 '12 at 15:17
  • if you research centos6 you'd discover, a lot of redhat Ent 4 packages are fully qualified since they are based on the same base install. Also note before providing this answer I ran it in Virtualbox on fresh install of centos6 without issue. – tao Jul 24 '12 at 17:35
  • Hi @tao thanks so much for the answer. I installed it with the exact instructions as you put them above, except for the sudo, since I am logged in as root, and I get sudo: command not found. Trying to run the service, I get: unrecognized service. Could you possibly help me solve this please. thanks in advance. – louis_coetzee Jul 28 '12 at 21:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.