I have a clean install of a Windows 7 Ultimate x64 SP1 guest installation under VirtualBox 4.1.8 (lastest as of this week) (and running on OS X Lion host). I am trying to install Oracle's paravirtual network drivers and I am running into problems.

I am getting the drivers via Oracle VM Windows Paravirtual (PV) Drivers (which needs an Oracle login to access)

I navigate to the "Oracle VM 3.1.1 Media Pack v1 for x86_64 (64 bit)" (May 2012)

And download the "Oracle VM Windows Paravirtual (PV) Drivers for Microsoft Windows Guests", then extract the .exe from the zip file and start the installation in my guest system.

This is where it all goes wrong. During the installation I get two error dialogs popping up one after the other:

Error 1 Error 2

After I have closed these dialog boxes the installation proceeds without any other errors. Yet when the guest reboots there is no additional network drivers available (when I expected to see the VirtIO driver in the guest).

I have also tried installing the previous version (3.0.3 Feb 2012) but that gets basically the same result (and exactly the same error dialogs). I will try even earlier versions (2.2.2 Jan 2012) but I don't expect any different.

Does anyone have any ideas as to what I am doing wrong?

Thanks Peter


I just installed the 2.2.2 drivers and the installation ran with no errors. However After the reboot I still see no VirtIO network adapter anywhere. Arghhh!!!! What am I missing?

  • VirtualBox has a community forum I would ask there. – Ramhound Jul 23 '12 at 13:59

VirtualBox Guest Additions do not include the virtio-net driver, and Oracle VM's driver installer is intended for guest operating systems running under Oracle VM Server (Oracle's hypervisor based on Oracle Linux), not VirtualBox.

To install the virtio-net drivers, download them directly from the KVM project page, as it states in the VirtualBox manual.

|improve this answer|||||
  • 1
    Yep I failed at reading comprehension today. I had looked at some of that information and discounted it because I couldn't get my head around downloading a windows driver from a linux distro for an Oracle product (that and being tired and rushed) – Peter M Jul 23 '12 at 18:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.