Skype got stuck, and Windows was unable to kill the process even when the UI had disappeared. I had to restart the computer to get Skype again working.

Running as administrator:

C:\Windows\system32>tasklist | find "Skype"
Skype.exe                     2708 Console                    1     92,328 K

C:\Windows\system32>taskkill.exe /pid 2708 /F /T
SUCCESS: The process with PID 2708 has been terminated.

C:\Windows\system32>tasklist | find "Skype"
Skype.exe                     2708 Console                    1     92,328 K

How can this be even possible?


  • 1
    I'm not sure what would cause this, but in the future you can use Process Explorer to kill it. Never fails for me even if Task Manager does.
    – Oliver G
    Jul 24, 2012 at 9:48
  • 1
    I don't know why this happens, maybe some system-wide lock or something. But this happened to me several times. The application was basically "unkillable", no matter what utility I tried. Even Process Explorer failed. Restart was the only way out.
    – Apache
    Jul 24, 2012 at 11:05
  • 2
    Skype is not shutting down. Looks like the problem with Skype is pervading in all platforms. Find the same problem in Ubuntu. Jul 24, 2012 at 12:24
  • Microsoft already killed Skype
    – Troydm
    Jan 25, 2018 at 16:54

6 Answers 6


Unkillable Skype is caused by one of the Skype threads trying to close a handle to the Ancillary Function Driver (/devices/AFD).

This close call hangs and never returns. When you try to kill the process, the I/O request gets cancelled, but the cancellation also hangs. The process cannot quit until its threads return, and the thread cannot return until the cancellation completes, hence process termination is impossible.

You can confirm this with a kernel mode debugger. See this TechNet blog article for details.

You need to use a remote debugger, because Skype causes some unhandled exceptions which will freeze windows otherwise.

The probable cause is some bug in some network filter driver.

  • This seems to be the problem, and it crashes web skype too Feb 4, 2016 at 20:07
  • Sounds reasonable, but what to do about it !?
    – TT--
    Dec 11, 2018 at 18:54

Try again Taskkill with these switches:

taskkill.exe /f /fi "status eq not responding"

You may also look in HKU\Control Panel\Desktop and change the value of WaitToKillAppTimeout from the default value of 16000 (milliseconds) to a lower value (but not 0!) and HungAppTimeout from the default value of 4000 (milliseconds) to a lower value (but not 0).

  • 1
    Unfortunately did not help in my case, which matches given description.
    – JRA_TLL
    May 19, 2017 at 11:33
  • It helped me killing Skype, which was not appearing in Task Board also.Thanks
    – Vishnu
    Nov 8, 2017 at 3:46

The process name is for Skype for Business is "lync.exe", but the Process Description is Skype for Business"

Try taskkill.exe /IM lync.exe /F

  • Please read the question again carefully. Your answer does not answer the original question.
    – DavidPostill
    Feb 3, 2017 at 14:09

Doesn't seem to be issue in my case either.

c:\Windows\System32>tasklist | find "Skype"
Skype.exe                     8380 Console                    1    133,628 K

c:\Windows\System32>taskkill /pid 8380 /f /t
SUCCESS: The process with PID 10296 (child process of PID 8380) has been termina
SUCCESS: The process with PID 8380 (child process of PID 3616) has been terminat

c:\Windows\System32>tasklist | find "Skype"


However, in your case, it appears to me that the process' UI-thread is locked in closing state while the SUCCESS message was displayed.


If that happen, click on (show hidden icons) arrow on taskbar, you will see that the app icon is still there. Hover over icon and you will see it disappear! Run the command again and you will not find the process again, which indicates that process was closing, unusable and inactive.

  • Unfortunately did not help in my case, which matches given description.
    – JRA_TLL
    May 19, 2017 at 11:33

Make a new shortcut. Enter "C:\Program Files (x86)\Skype\Phone\Skype.exe" /shutdown in the location line then name it kill Skype


  • This works for me. (Microsoft stuff is such a horrible pile of excrement). Jul 10, 2016 at 23:31
  • Unfortunately did not help in my case, which matches given description.
    – JRA_TLL
    May 19, 2017 at 11:33

I think I have the answer, and a way to kill the skype process with a simple shortcut that you can create yourself. It always has worked for me, with any version of Skype.

here are the steps :

  1. Right-click the empty section of the desktop and select New

= > Shortcut

  1. Type this in the window that opens:

    taskkill.exe /IM skype.exe /T /F

Then hit Enter (or click on ‘Next’)

  1. Type in the name for the shortcut (could be SkypeKill) and click ‘Finish’ (or hit Enter)

  2. optional : you can choose and add a nice red skype icon to your shortcut ; download one in google images, place it in a secure file you won't move.

then, right click the shortcut, properties, change/modify the icon, browse to find the folder with your icon file.

  1. also optional : Pin (drag) the shortcut to the taskbar so Skype can be closed and shut down with a single click on this taskbar icon.

That’s it. What this does is:

/IM gracefully closes a process with the “image name”


/T closes all associated processes skype.exe opened

Hope it will work for all of you too, let us know if it does or not by publishing an answer here :)

  • This just repeats earlier answers
    – Ramhound
    Jun 20, 2015 at 16:39
  • 1
    @Ramhound: Actually, it's worse than that.  The question says, "X doesn't work; what can I use instead?" and this answer is saying, "Try X; it has always worked for me." Jun 20, 2015 at 17:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .