I run synergy server on my Windows machine, and the client on my Mac. When i used emacs23, all keys were recognized properly. I just upgraded to emacs24 and now the control key from the Windows keyboard doesn't work, e.g. Ctrl-n or -f do not move the cursor down or forward, though the control key is still recognized outside of emacs.

Other notes:

  • I have both machines' caps lock keys made into a second control key.
  • When i hit Ctrl-n on emacs from the server's keyboard, it's as though emacs24 is stalling because nothing happens until i hit another key, e.g. a-z.

UPDATE: opened a bug ticket at http://synergy-foss.org/spit/issues/details/3324/

  • It's perfectly possible this is a bug. Historically, i have found all kinds of weird bugs with the keyboard and Synergy. Have you tried posting on the official Synergy Foss Question site? – Oliver G Jul 24 '12 at 14:20
  • Done: synergy-foss.org/osqa/questions/1892/… – nymo Jul 24 '12 at 14:46

This was a bug in emacs. It's been fixed (as per your bug report), and the 24.2.1 version for mac works as expected with synergy for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.