1

I was copying a few files over onto a directory and suddenly I noticed that there was already a directory that I previously had! So I decided to delete it. Now something happened and I decided to skip the copy and I removed the drive!

Now I was copying the files in a directory called zSHARE , and the already existing directory inside it is DataMode. Now I can rename those two directory but I cannot delete them. I get an error saying that cannot remove Directory not empty!

I tried

sudo rm -r 

and

sudo rm -r 

Commands too no luck! I decided to attach it to my Windows machine and it won't detect system slows down and when I remove it gets its pace back!

Also when I run chkdsk /R H: on the drive it won't run but as I remove the drive it shows its a RAW partition.

The drive detects everthing on linux but not on Windows! I even resized the partition and ran ntfs fix still no luck

Can I get it back to working in Windows without having to backup entire drive and den reformat and copy over?

4
  • Is this external hard drive a SAN? en.wikipedia.org/wiki/Storage_area_network Seems like a random question, sorry, but I seem to recall working with a SAN branded zShare at some point. Jul 24 '12 at 20:21
  • oh LOL no.... i use this folder to transfer movies and tv shows ... the reason z is small and SHARE capital is cause, my TV has a usb and sorts all small letters in the last so when i attach i just go left once to select the folder and enter instead of going through tons of folders on right! Jul 24 '12 at 20:30
  • What windows version you are using?
    – Maximus
    Jul 24 '12 at 20:34
  • Windows XP and Windows 8 Jul 24 '12 at 20:42
2

It sounds like you either A) formatted the drive to something other than FAT32/NTFS, or B) the partition is corrupt. While mounted in linux what is the file system type?

df -H

What error do you get when you run?:

sudo rm -rf

Finally does the drive show RAW in the disk managment utility in Windows? If so, and you know that the partition is NTFS, you likely have a corrupt partition and should copy the data off while you have it readable in Linux.

3
  • out out of the first command doesnt show any FS type /dev/sdb1 485G 378G 107G 78% /media/Passport The is the outout for the delete command sarvesh@sarvesh-laptop:/media/Passport$ sudo rm -rf 'DELETE THIS' [sudo] password for sarvesh: rm: cannot remove `DELETE THIS/sdf': Directory not empty sarvesh@sarvesh-laptop:/media/Passport$ Jul 24 '12 at 20:41
  • also when i see the drive in gparted it shows as NTFS Jul 24 '12 at 20:42
  • 1
    How does it show in the disk management utility in Windows? On your linux install you install the ntfs-tools package and then run ntfsfix to attempt to repair the partiiton. Jul 25 '12 at 15:24
1

Expanding on David George’s comment, it appears that Puppy Linux for example has built in support for ntfsfix. Example

ntfsfix /dev/sdb1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.