128

I put my multi-monitor system to sleep when it's not in use. After I wake it up, all windows are repositioned to a different screen. The closest pattern I can think of is that the windows there were on the main screen switch to a the second screen. It looks like it disconnects the main screen before it goes to sleep which in turn switches all the windows to the 2nd or 3rd screen.

Edit: Here's the video card I'm using --> SAPPHIRE FleX 100322FLEX Radeon HD 6450

  • 1
    You need to specify the graphics adapters you're using, this is probably their fault. – Shinrai Jul 25 '12 at 15:27
  • 4
    I found the definitive solution to this: do as Stephen, (st99), says here in the ninth answer – Soldeplata Saketos May 3 '18 at 8:48
  • same issue is on kubuntu, anybody have a solution for that? – Waqleh Sep 3 '18 at 10:58
  • Unable to add as an answer, but having read this answer and this answer, I found the solution to be a manipulation of HKLM\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration. With all additional monitors disconnected, delete all keys at this path and restart PC. Note new key added to this path (A). Reconnect monitors and note further new key added (B). Set up display settings as desired. New key will be added again (C). Each key represents a display config. Delete the undesired key (probably key B). – Neo Sep 15 '19 at 20:54
  • I've had a couple PCs at work experiencing this issue. Both were Windows 10. First had Intel HD Graphics 530 and the new one as of a couple days ago has Intel UHD Graphics 630. I didn't have this issue at all with Intel driver 22.20.16.4771, then Windows automatically updated to 24.20.100.6344 and I started noticing the issue. Rollback fixed it. Two times after that, Windows automatically updated to 25.20.100.6446, the issue came back, I rolled back to resolve it. New PC has 26.20.100.7262 and has the same issue. I'm trying to find a solution since I can't simply roll back to 22.20.16.4771. – Pilot_51 Feb 7 at 13:37

13 Answers 13

34

The issue is most likely with the graphics driver. Whenever a single monitor is disconnected from a multimonitor setup in Windows, Windows will attempt to move everything from that screen onto the remaining screen(s). Usually, this will not occur when suspending/hibernating/shutting down the computer. Thus, it is probably because of the graphics driver doing one of the following:

  • 'Disconnecting' the monitors when you put the computer to sleep, so when Windows awakens, it must re-determine where to place everything.
  • Recognizing the monitors in a different order each time you bring the computer out of sleep, forcing Windows to rearrange your application windows.

Check to see if there is an update to your graphics driver by going to the chipset manufacturer's website.

| improve this answer | |
  • 1
    FYI: My drivers are from Intel, so I presumed they were signed and distributed with Windows Updates, but they were not. – Leo Oct 18 '15 at 11:49
  • 1
    Similar problem here. I have a Dell laptop with nVidia graphics adapter. Installing a newer driver from nVidia instead of the Dell driver fixed the problem. – Chris Jones Dec 17 '15 at 23:18
  • 1
    similar Problem here. latest OEM Intel HD 4600 drivers. may be I should check Drivers from PC Vendor (HP)? – Falco Alexander May 29 '16 at 11:33
  • 2
    Same problem with a 7i5bnk NUC - got latest intel drivers – niico Jun 30 '17 at 16:11
57

This is an old question, but if anyone arrives here with the same issue, I suggest trying the solution posted here:

http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/windows-7-movesresizes-windows-on-monitor-power/1653aafb-848b-464a-8c69-1a68fbd106aa

I'm running Windows 8.1 with two 2560x1440 displays on DisplayPort. When waking from sleep, all my windows had been pushed to one display, and some of them resized. This fixes the issue for me; now all my window positions and sizes are preserved. Here is the relevant link content:

I have found a work-around. Using Sysinternals ProcessMonitor I found that Windows was accessing the following Registry path:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration

My system had three entries:

  • DELF003YY7707BR0MUL_30_07D7_6A^9A3774EB79DEE3E3E38496CC7DF4D936
  • QHD32000001_31_07D6_D5^63E1ABDD175E7871DCAEB710418A0F75
  • SIMULATED_8086_2A42_00000000_00020000_1010100^CDE365D1B3F0942F0CF38BFB8E127AB4

Under each is a tree called 00. Two of the keys are:

  • PrimSurfSize.cx
  • PrimSurfSize.cy

Under 00 was another branch also called 00. Two of the keys are:

  • ActiveSize.cx
  • ActiveSize.cy

In the first two configs (i.e. DELF00... & QHD3...), the above keys were 1440x900, so they were not involved.

The third (SIMULATED...) were set to 1024x768.

I changed these to 1600x900 and the problem was solved.

Further I changed resolution (via control panel) to 1920x1080, the moving/resize issue returned, but the lower right corner was set to 1600x900, ie the SIMULATED... settings.

So for some reason one of the configs does not get set correctly.

I don't know why there are three configs, I have only ever used one monitor.

| improve this answer | |
  • 23
    Simply delete the whole HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration, it works as well and it's faster. – FarO Oct 25 '16 at 21:55
  • 3
    Deleting the entry does not work for me (Windows 10). As soon as I turned of the monitor, the 'SIMULATED' entry is created again. Original solution works (ie. modify each occurrence of 1024,768 with actual resolution). – FractalSpace Feb 10 '17 at 16:22
  • 2
    Here's another related post I found on Microsoft Answers for Windows 10. answers.microsoft.com/en-us/windows/forum/windows_10-hardware/… – Chiramisu Mar 14 '17 at 22:39
  • 1
    Deleting the whole configuration as @OlafM suggested works perfectly. In my case, windows hat about 30 entries. After rebooting, only one was re-recreated, containing only the monitors I have actually plugged int. – maja Jun 9 '17 at 20:54
  • 1
    I was nervous about deleting everything in the Configuration folder but I made an export first and deleting everything fixed the issue, after resume I had to set the monitor order and it no appears fixed. – drooh Feb 13 '18 at 19:03
16

If your computer has Intel HD Graphics you have to set Extend Display options (and resolution settings) from the Intel Graphics Control Panel. If you do it from the Windows Display settings it will reset after you wake it from sleep mode.

Here's a screenshot.

enter image description here

| improve this answer | |
  • It didn't change anything for me. Or do I have to completely wipe the windows settings before doing it with the Intel software? – Christophe Drevet-Droguet Sep 28 '17 at 13:40
  • 1
    It worked for me after I reset the settings and then applied from the Intel graphics. – Tidhar Klein Orbach Nov 7 '17 at 11:38
  • I merely switched some option and then reverted it back. It enabled the "apply" bouton and saved the config from the driver. Works great after manual lock. I wll see what happens after a long period – Aldian Jul 11 '18 at 9:56
  • This worked for me on Windows 10 and saved my sanity. – shoelzer Oct 18 '18 at 15:01
9

I think I found a workaround for this issue by combining the ideas from these posts.

(my PC is Windows 10 TH2, Intel HD4600 with HDMI port, Changhong 4k monitor)

Here is the procedure.

  1. Delete all extra registry entries under ...GraphicDrivers\Configuration and GraphicDrivers\Connectivity, leaving only the entry corresponding to my monitor (MST00301...)

  2. Before putting monitor to sleep, just type "WIN" + "D" combo key to minimize all desktop windows.

  3. After turning on monitor, type "WIN" + "D" again to restore all windows.

| improve this answer | |
  • 1
    I think Win+D is not needed. After deleting all the entries and restarting the pc the external monitor is added again to the registration. After that it seems to work as expected. Maybe windows was confused of to many different configurations. In my case I had 12 entries and now there are only 2: maxrev.de/… – mgutt Apr 5 '16 at 15:22
  • This worked for me, but only after correcting the new SIMULATED_ ... key. After the restart, I had two new entries under Configuration and Connectivity. The SIMULATED_ 00 entry had 1024, 768 and 4096 for cx, cy and stride values, which are wrong. I copied just those values from the other key, which appeared to be correct for my monitor, and rebooted. I have a single 40" 4K monitor, a Wasabi Mango UHD400 and problem is now fixed. – pixelgrease Sep 10 '16 at 15:21
  • For me, the Win+D trick works, even without altering the registry, which did not work. Note that the Desktop does not have to be minimized: the Desktop icons that are outside the 1024x768 box will not be moved after turning the monitor off and on again. Also, maximized windows do not suffer the resize/move problem. – Roland Feb 22 '18 at 13:29
5

Not all NVidia cards support the ability to fake the EDID, and it isn't just Sleep that causes this problem. If a monitor is turned off or disconnects briefly, it can wreak havoc on a carefully configured screen layout. As none of the solutions here worked out for me, I wrote a utility to restore the window positions when the number of monitors change. It is available with source code here.

| improve this answer | |
  • 1
    I've tested @GarrGodfrey 's program and it worked like a charm. – Kita Dec 1 '18 at 16:27
  • This also seems to work well for me, nothing else seemed to work, I'm on a Legion y540. – math0ne Jan 15 at 20:03
2

Usually this will be caused by the graphics driver not properly supporting sleep modes and therefore disabling the ability to detect a connected display when the computer goes to sleep.

Update your graphics drivers from the manufacturer to resolve the issue.

If the issue is still not resolved after updating the drivers, it may be due to an unusually reported display ID (EDID). You can usually force the detection of a monitor within the graphics driver control panel.

However if this is unavailable, you can use the Windows Resolution window to detect devices while the monitor is disconnected, then select the display which will report “Another Display Not Connected”, then under Multiple Displays, you can drop down and select “Try to connect anyway” which will broadcast a signal to the monitor over the port type you have selected (the signal will not be interactive), then connect the display which should interpret the signals sent to it properly.

The forced resolution will override detection of the screen and should persist through sleep.

| improve this answer | |
  • Do you know a way to enable this setting if the monitor is still connected? I wonder if that will fix my windows slightly moving after wake. – Ahmed Nov 1 '19 at 3:55
  • I tried turning off a monitor (while the VGA cable is still connected) and it disappears from the multiple display configuration in Windows 10. Even after clicking Detect it doesn't give me any way to "Try to connect anyway"... any ideas? – Ahmed Nov 1 '19 at 4:45
2

Same problem here with Windows 8.1 and Macbook Air 2013 (Intel HD Graphics 5000). I try everything. Finally I went to Intel updated with the latest drivers for my graphic card and the problem continues. Then I went to the graphics property, with my second display turn on in Multiple Display I choose 'Disconnect this display', then after the second display disconnected I select extend my desktop and the problem dissapear. Hope this works for you.

| improve this answer | |
  • I also have a Macbook Air 2013 with latest drivers and that didn't solve my problem. Do you any ideas how can I solve it? – Andrew Jul 8 '14 at 14:20
2

In my case, with three 1920x1080 monitors arranged horizontally, it seems to have been fixed by going to the registry key mentioned in other answers (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration), finding the key starting with SIMULATED, then changing all the values of 1920 under that key to 5760 (1920 times three, for the three monitors).

I'm guessing the SIMULATED key is used for when the PC goes to sleep, but Windows still needs to maintain a desktop in the process of going to/resuming from sleep, even when the actual monitor(s) may not report themselves yet.

| improve this answer | |
  • This is what helped me the most. Your second paragraph especially seems to be correct. Though I still have windows move to other monitors when the screen is off. – Andrew Dec 7 '17 at 2:11
1

For me, the fix was https://superuser.com/a/908156/238666 . Summary: Windows fails to read the EDID info from the monitor at wakeup, and in the Nvidia control panel you can save the EDID info to a file and set the pc to read it from that file, under the the Task: Workstation, View System Topology, EDID Source.

In my limited view, the root problem could be the Nvidia card, but also Windows, DisplayPort, or the monitor (Lenovo X1 4K)

| improve this answer | |
0

I solved with this little application:
https://github.com/hunkydoryrepair/MonitorKeeper/releases

Just run it, and it will be maintain windows in same posizion.
Thank you very much @hunkydoryrepair.

| improve this answer | |
0

Win Redock has worked best for my use case - which was restoring window positions after a display-change. Redock is automatic - saves and restores windows without any intervention. Its open source too.

So if your issue is that your laptop has a display hiccup when it wakes up, this might help you.

| improve this answer | |
0

I "solved" this problem with DisplayFusion.

It can run triggers on various Windows 10 events, so I told it to save the window positions when the desktop is locked, and restore them when it's unlocked. See the settings dialog below.

This isn't perfect: When I unlock, I have to wait a few seconds while it moves each window back to its previous position. But it's a lot better than everything getting stuck on one monitor every time I lock my machine (a dozen times a day or more).

DisplayFusion Settings Dialog - Triggers

| improve this answer | |
-1

Like it or not, but according to Dell's known problem with specific 4k monitors link: http://www.dell.com/support/Article/us/en/19/SLN295708/EN I had to switch from 59/60Hz to 30Hz on my 3 x Dell P2415Q 4K UHD on Intel 4600 connected with display's stock DP/mDP and it helped me - as Dell KB article says. It applies to UP3214Q and P2715Q too.

The issue didn't manifest on lower res QHD Dell U2515H + same video/PC

Registry keys removal and driver updates were not helping.

Upd 2018/08: And upgrading graphics card to NVIDIA Quadro P600 didn't fix the issue, so staying on 30Hz.

| improve this answer | |
  • 1
    Urgh, 30Hz is awful to use, so stuttery. – Simon East Mar 19 '17 at 23:51
  • @SimonEast, it's been a year since I posted this answer and use these 4K-s in 30Hz, being sensitive to fluorescent and LED flickering, and preferring DC 12V Halogen lighting where possible, I'd say 30Hz is OK on these 4K Dell monitors. Youtube action vids are relatively smooth, but I mostly use these screens for code, terminals, mails and chats - don't feel tired after 10-12 hours per day.. – kuz8 Mar 21 '17 at 2:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.