1

I've got this configuration:

  1. Ubuntu 12.04 hosting a directory tree full of files to be served by a webserver
  2. VirtualBox running WindowsXP Service Pack 3 with IIS

XP and Ubuntu are connected to one another via a host only virtual NIC. There's Samba installed and running on Ubuntu and exporting one share point; IIS on Windows configured to use that Samba share as the root directory of the website it's serving1.

It all works, except for one thing: I need to protect with basic authentication one of the directories within the website. If I run the site locally to Windows, authenticating with a windows user works flawlessly, if instead I run the site on the Samba share, the same user and the same password don't work. I even tried using my Ubuntu user login and password, but to no avail.

Does anybody know how to solve this issue, and where it stems from?

__

1 I couldn't use a vbox shared directory, it would just not work.

1
  • I'm having this same issue, did you ever find a solution? In my case IIS is running as admin, so i was going to use a mapped drive to the samba share, but its getting too complicating of a setup if i have to map the network drive on admin account. Aug 18, 2017 at 18:09

0

You must log in to answer this question.

Browse other questions tagged .