10

So I've seen several posts say that installing Guest Additions for VirtualBox 4 running Ubuntu (host is Windows 7) should allow you to set a resolution higher than 800x600. There is also this answer on SuperUser, but the last comment says its deprecated for VB4.

I have installed guest additions, but the max resolution is still 1024x768. I want to up it to at least 1280x1024. I have set the display memory for the box at the max of 128.

Is this just as good as it gets, or am I missing something?

0

5 Answers 5

7

Make sure to turn off the VM.

Then go to VirtualBox Manager > File > Preferences > Display, click the Maximum Guest Screen Size dropdown and make sure to select either None or Auto (whichever works best).

A picture says it all

3
2

What worked for me in the end was to increase the video RAM size for the virtual machine from the default of 16MB to 128MB (maximum guest screen size: none). With 16MB there was no way I could make it work (at the time of this post), although it worked fine previously for quite some months.

I have to mention that I'm running Kali instead of Ubuntu in the guest (host is Windows 10), but since they're both debian-based this still might apply for some people.

1
  • 1
    Increasing video RAM was the secret step for me (VirtualBox w/ Ubuntu, on a Win10 host). Apr 1, 2020 at 22:58
0

VirtualBox is supposed to resize the guest display to the size of the VirtualBox window on the host (if you select the relevant option). But unfortunately it's finicky.

Try resizing the window and waiting a few seconds. Repeat a few times if necessary. If that doesn't resize the guest, try rebooting the guest.

0

Funny, I accidentally ran Windows 10 as Type: Linux system in settings, this made windows not to detect any VB devices and resolution was 1024

enter image description here

0

As https://forums.virtualbox.org/viewtopic.php?p=329477#p329477 and https://superuser.com/a/1210957/904401 demonstrate, changing:

  1. File
  2. Preferences
  3. Display
  4. Maximum Guest Screen Size

from Automatic to None should provide this capability. However, as VirtualBox resolution maxed at 1024x768 after Guest Additions explains, it still didn't allow me to use https://sourceforge.net/projects/blissos-x86/files/Official/BlissOS15/Gapps/Generic/Bliss-v15.8.6-x86_64-OFFICIAL-gapps-20230703.iso on any resolution greater than 1024 by 768 pixels.

I consequently expect, as https://superuser.com/a/1340791/904401 and https://github.com/BlissRoms-x86/support/issues/35#issuecomment-1889652945 together demonstrate, that hardware acceleration must be enabled by the host and client OS, and it must be functional.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .