4

I've recently installed X and SLiM but when I wanted to login it wouldn't let me. It keeps asking for username. (virtualbox)

My /.xinitrc:

DEFAULT_SESSION=ck-launch-session dbus-launch openbox-session
case $1 in
openbox)
   exec ck-launch-session dbus-launch openbox-session
xfce4)
   exec startxfce4
*)
   exec $DEFAULT_SESSION
esac

Log: (1st is username attempt, 2nd is root attempt)

slim: waiting for X server to begin accepting connections

slim: waiting for X server to shut down


slim: waiting for X server to begin accepting connections
slim: pam_authentication(): Authentication failure
9
  • It keeps asking for the password, or it logs in, tries to create the X-Session, then fails and throws you back at the login?
    – Bobby
    Jul 26, 2012 at 12:18
  • I enter my username&password but it keeps asking for them. In the logs it says "failed to authenticate" Jul 26, 2012 at 12:20
  • And you are sure you are entering the correct credentials?
    – Bobby
    Jul 26, 2012 at 12:21
  • Yea, when I press Ctrl+Alt+F1 I can easily log into the console. Jul 26, 2012 at 12:22
  • 1
    According to the wiki, login information may be wrong in the logs, so this could be another issue. Check again after correcting this, maybe : wiki.archlinux.org/index.php/SLiM#Login_information_with_SLiM Jul 26, 2012 at 12:47

3 Answers 3

1

For reference, the archlinux wiki is a treasure trove : https://wiki.archlinux.org/index.php/SLiM

There is a typo in your script. All clk-launch-session should read ck-launch-session

Also, did you make .xinitrc executable ?

chmod +x ~/.xinitrc
6
  • oh sorry, that ck-clk mistype is only here, in the actual file it's alright. Jul 26, 2012 at 12:37
  • but this doesnt work :[ Jul 26, 2012 at 12:52
  • Could you fix the logs issue as asked in my previous comment, show us the logs and fix the typo in the question ? Jul 26, 2012 at 13:54
  • I tried to but I'm a bit new to Linux. I'm usually able to work out these errors but now.. Jul 26, 2012 at 14:04
  • From the log, it seems that authentication did not fail on user login, so it may be the window manager. Jul 26, 2012 at 14:10
1

You have to do a bit of extra work to start X in virtualbox with archlinux. You can find it on the wiki here, copied and pasted below.

Installing Arch under VirtualBox is straightforward, and additions should be installed through pacman (not through "Install Guest Additions" in VirtualBox, or a mounted ISO.) Follow these instructions after doing a basic install of the X-window system found on the Beginners' Guide.

Guest additions package

Install virtualbox-archlinux-additions.

Kernel modules

Manually load the VirtualBox modules with

# modprobe -a vboxguest vboxsf vboxvideo

Auto-start modules

To autostart these modules each time you boot, you can add the three modules above to the MODULES array in /etc/rc.conf.

MODULES=(... vboxguest vboxsf vboxvideo)

Enable VboxClient-all

The VBoxClient contain these services(/usr/bin/VBoxClient-all) (copy/paste...) :

 --clipboard        start the shared clipboard service
 --display          start the display management service
 --checkhostversion start the host version notifier service
 --seamless         start the seamless windows service

So you can Enable VBoxClient-all to start all these services.

If you are running something that launches /etc/xdg/autostart/vboxclient.desktop, such as GNOME, then you should be ready to go. If you use .xinitrc to launch things instead, you must add

VBoxClient-all &

to your .xinitrc before launching your WM. You should now be all set, and all guest additions should work properly.

5
  • I've done that modprobe and MODULES thing but I'm not quite sure how my .xinitrc should look like. I added that line, but it made no difference. Jul 26, 2012 at 19:13
  • put VBoxClient-all & a line above the case $1 in. I'll be heading home shortly and can help more when I get home.
    – Rob
    Jul 26, 2012 at 19:21
  • I did that and no effect. >< Jul 26, 2012 at 19:30
  • You can ask for help in #archlinux on irc.freenode.net with an IRC client, and I'll be back on to give you more information when I get home. What is the host OS?
    – Rob
    Jul 26, 2012 at 19:34
  • host OS? You mean the OS that's running VirtualBox? Win7 64 Jul 26, 2012 at 19:47
0

I am using OpenBSD 6.0 and I installed SLIM. I could login with root or my username. I made a huge mistake. I checked the box during logout labeled: "Save session for future logins". I could get in from then only as root but not my regular username. So through much looking around I found that I had a .cache/ folder. so I deleted all the saved sessions in ~/.cache/sessions/ and then I was able to login as my regular user again. Of course make sure you try a logout and ensure to uncheck that box before going through with the logout. I tried it and got back in no problem and no more sessions were saved in ~/.cache/sessions/ .

I hope this helps you all.

Kevin T

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .