13

I've upgraded to Mountain Lion yesterday and everything is working great except for one thing that's really really annoying,

When I press Cmd+Tab, I get the regular switcher, but only some of the open apps are visible, and every time I would have to open Mission Control just to switch apps.

Did anyone else bump into this issue, or even better - solved it? :)

4
  • Is it consistent or random? This sounds like an issue I've seen on older versions of OS X before.
    – jtbandes
    Jul 27, 2012 at 9:10
  • Completely consistent... Doesn't show all of the apps always unfortunately Jul 27, 2012 at 9:13
  • 2
    Do the missing apps show up in the Dock? What applications are missing?
    – Daniel Beck
    Jul 27, 2012 at 10:58
  • 1
    This never happened on Lion for me, but it's happening quite often on Mountain Lion. I'm sure
    – Grav
    Aug 2, 2012 at 9:50

7 Answers 7

3

I had this same issue right after I upgraded. In fact, the open app indicator in the Dock wasn't working for open apps either. I just restarted the computer and all is good now. The application switcher(cmd-tab) shows all open apps and the open app indicator in the Dock is working too.

2
  • 1
    I kinda noticed it keeps coming back after a while for some weird reason ... Jul 29, 2012 at 9:40
  • Restarting fixes it for a while, but it comes back again later =/
    – analogue
    Aug 28, 2012 at 21:44
50

To avoid restarting, you can just kill the Dock process and it will start up automatically, showing all open applications. Open the Terminal (Applications -> Utilities -> Terminal) and type:

killall -KILL Dock

The Dock will disappear and in a minute, reappear.

7
  • 1
    Indeed, that did the trick for me, thanks! Still would like to know what caused that glitch, though...
    – DaGaMs
    Jul 30, 2012 at 14:29
  • 1
    You can also launch the dock again manually using Spotlight (search for 'dock')
    – Grav
    Aug 2, 2012 at 8:51
  • Excellent answer, thanks. This has recurred for me even after a restart. (Most recent culprit is RDC client.) It's odd. I'm hoping it just sorta... goes away.
    – pluckyglen
    Aug 3, 2012 at 1:18
  • Opening "Dock" via Spotlight didn't solve it for me, nor did force-quit of Finder. "killall -KILL Dock" did, however. I'd set a cronjob for it, except that killing the Dock has the side effect of unhiding all windows. Not optimal.
    – cczona
    Aug 7, 2012 at 1:39
  • Thanks for this...I thought it was finder but relaunching that was not helping. I definitely prefer this to restarting the entire machine....at least until apple fixes the bug :)
    – TechieGurl
    Sep 10, 2012 at 17:35
6

I had the same issue after upgrading to Mountain Lion. I called Apple and after having to go through the usual PRAM reset I got onto someone who had some useful suggestions. The problem appears to be fixed now - I've not seem the problem recur.

The solution was to remove the plists for the Dock, Finder and Desktop. I suspect the Dock plist was the most important, as it is definitely a Dock related issue. Presumably in the upgrade process the plist has been corrupted in some way.

The plists in question can be found in ~/Library/Preferences. A quick way to get to the Library folder in Finder is to hold down Option then select Go from the Finder menu - Library will be in the list.

Inside Library open Preferences and find com.apple.dock.plist - send this to the trash or drag to the desktop. The other two that the Apple guy got me to remove were com.apple.desktop.plist and com.apple.finder.plist.

Now log out and in again (or do killall Dock from a terminal) - the Dock will recreate the plist. The Dock arrangement will now be back to default - you will have to re-add any apps you had there.

2

I am seeing the same problem, repeatably, with TextWrangler and TextEdit. Both are active and editing documents but not appearing as active in the Dock or in the app switcher. killall Dock fixes it, at least temporarily.

I suspect it's something to do with the new automatic termination feature in Mountain Lion - perhaps a bug that will be worked out in a .1 release.

3
  • 2
    Automatic termination was added in 10.7. But it might be a good idea to disable it with defaults write -g NSDisableAutomaticTermination -bool true and see if this issue goes away.
    – Lri
    Aug 6, 2012 at 18:13
  • It doesn't go away for me after trying this, only seems to affect Sparrow. It's showing the toolbar item, responds to keyboard shortcuts when it's the foremost app, but doesn't show as running in the dock/cmd-tab or force quit list
    – Nick
    Aug 27, 2012 at 11:13
  • Just to update my experience, there's actually a setting in Sparrow to hide it in the dock, which subsequently hides it in cmd-tab , very stupid
    – Nick
    Oct 3, 2012 at 13:25
1

I had the same issue. I was able to quit all the open applications that were displayed in the switcher at the time, Finder crashed, and when it came back it was working correctly again.

1

I was having the same issue on Mountain Lion, Command-Tab was not working when switching apps and I had to click on the Dock to actually switch to the app. The issue was resolved by going into System Preferences | Mission Control and selecting the checkbox for When switching to an application, switch to a space with open windows for the application.

0

I took Will Roe's terminal command and made a quick AppleScript app to run it easily. Since I get this bug every time I turn my computer on from a Shut Down, I have it in my dock for easy fixing. Enjoy!

Download (VirusTotal scan results)

1
  • 2
    Welcome to Superuser! While this may fix the problem, most users are wary of running scripts without seeing the source code; are you able to edit your question to paste the code in the script? Aug 7, 2012 at 20:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.