I'm currently trying to install Solidworks 2012, but every time I launch the installer, I get an error:

Registry Permissions:The Installation Manager encountered an error when trying to 
create registry keys in this location of the registry:
HKLM\Software\Wow6432Node\SolidWorks\SolidWorks 2011\PDMWorks
HKLM\Software\Wow6432Node\SolidWorks\SolidWorks 2011\PDMWorks Workgroup

If I ignore this error and continue with the installation, it eventually returns another error about 10% of the way through the install with more complaints about the registry and then it just fails to install the program. To fix this, I figured that I would delete these registry keys and allow SolidWorks to remake them, however, when I attempt to delete them, I get the following:

  • Trying to delete the parent \Solidworks\ returns a default error that says "Error Deleting Key"
  • Clicking on either of the PDMWorks returns "PDMWorks/Workgroup cannot be opened. An error is preventing this key from being opened. Details: Access is denied."

I've tried a bunch of Microsoft solutions, including Microsoft Fix It, PsExec and RegDelNull, along with trying to assign permissions to the key and taking ownership (which errors out to access denied again), but none of these work.

Is there any way to remove this key without reinstalling Windows?

edit: I was able to remove the AddIns and the PDMWorks keys by adding a new key to the registry under those directories - this allowed me to see the files that were hidden in them and modify the permissions for those individual files. The problem now is that there's another directory under \PDMWorks Workgroup\ as \Default, and I can't add a new key to this to see what's inside, or change the permissions on it (because I guess there's a key underneath).


Regestry keys, like files, have permissions on them. Right click on the folder for the key you are trying to find out about and see if you can click on permissions.

If you can not even do that there is a hack you can do to run a app as SYSTEM instead of administrator.

Go download PsExec. Open a command prompt as administrator (by right clicking on the command prompt shortcut and clicking run as administrator). Run the following command:

psexec -i -d -s c:\windows\regedit.exe

This will launch regedit with the system account (make sure you do not have any copies open already) and see if you are able to delete those folders.

P.S. Check to see if solidworks created any users or groups on your machine and delete them (delete the corresponding folder in the C:\Users folder too), I had a similar issue when the user SQLServer installed got corrupted, the only sign was a registry key could not be created/deleted during the setup process.

  • I used what you said with psexec to open regedit before (I should've clarified that in my post), and I still couldn't delete the key. I've tried removing all the folders that contain "SolidWorks" from every folder I can find - AppData, ProgramData, Common Programs, etc, along with searching all of my drives for "solidworks" and deleting any folders that come up with that. – John Jul 27 '12 at 23:06
  • Worked perfectly for me. I had a registry key that could not be taken ownership of, but as system I was able to! – Peter Aug 18 '12 at 2:13

If you have access denied than you are not an administrator , or you have opened regedit without rights elevation (UAC prompt). As an administrator you should have permission everywhere.

  • 2
    Some registry keys are not readable/writable as administrator. – Scott Chamberlain Jul 27 '12 at 22:53
  • I'm an administrator and I've tried force opening as admin with no luck. – John Jul 27 '12 at 22:57
  • Well I have set for one of my keys permission Denied for Administrator to just check if my App I am making works perfectly and then I got stuck not able to change permission back for Adminstrator... Well I just locked myself out – Martin Krajčírovič Aug 28 '18 at 22:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.