3

I've been trying to install Windows 8 32-bit on the latest version of VirtualBox since yesterday. I run VirtualBox on my regular Windows 7 32-bit install.

Win8 installs fine, then goes to restart after the installation. After that, nothing. No matter how many times I restart the virtual machine, all it does is go to that black screen with the word "Windows" on it. There is no spinning loading icon and it never boots. I've given Win8 1024MB of RAM and 128MB of video memory.

I've reinstalled it twice now. Is there anything else I can do or any settings I can change? I've Googled this and all I found was a bunch of tutorials on how to install it in VirtualBox. I followed this tutorial to install it on VB.

Thanks.

8
  • silly question but this would be the RP right? I vaguely remember the older versions had issues with virtualbox
    – Journeyman Geek
    Jul 28, 2012 at 2:48
  • Try assigning more CPU cores.
    – user3463
    Jul 28, 2012 at 2:57
  • also try giving it more video ram, and enabling 3d acceleration
    – Doon
    Jul 28, 2012 at 3:03
  • @JourneymanGeek Yes, I believe it is the RP. Jul 28, 2012 at 5:18
  • @RandolphWest I've given it two already, thanks for the tip! Jul 28, 2012 at 5:18

3 Answers 3

0

Windows 8's kernel requires PAE/NX to be on.

Try this: In VirtualBox, click Settings > System > Processor and check the "Enable PAE/NX" box. Click OK, restart your virtual machine.

2
  • Thanks for the answer! I have turned on PAE/NX before and it has not worked still. Aug 3, 2012 at 23:22
  • You may need to re-install Windows 8 now that you've turned the PAE/NX on...?
    – Kinnectus
    Oct 5, 2015 at 7:25
0

This is more of a workaround but you could give VMware's VMPlayer or Microsoft's VirtualPC a shot. Both are free.

-2

I could be related to uefi bios secure boot. It is required in Windows 8

http://www.neowin.net/news/microsoft-clarifies-windows-8-uefi-concerns

Here is the ticket with VirtualBox that explains their lack of support for UEFI secure boot.

https://www.virtualbox.org/ticket/7702

4
  • 1
    Windows 8 will boot on UEFI without secure boot. Aug 2, 2012 at 16:57
  • 2
    @AriPernick It will even boot on the legacy AT-style BIOS.
    – kinokijuf
    Jan 25, 2013 at 20:42
  • @kinokijuf confirm. I run it on a older Intel Atom tablet with no UEFI at all.
    – sinni800
    Mar 5, 2014 at 14:56
  • 1
    It is not required, but "heavily recommended" by Microsoft. You can boot either in BIOS mode, UEFI mode with or without SecureBoot. But at least for Windows 8.1 UEFI without SecureBoot you'll get a message at the bottom-right angle of the desktop saying SecureBoot isn't configured correctly. The last link you provide says indeed that Windows can't be booted from the VirtualBox's UEFI firmware. But it works in legacy BIOS mode. That's not related to the problem here.
    – piernov
    Jul 6, 2014 at 10:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.