6

I am using the Screen Sharing application on a Macintosh running OS X Lion. I use Command-Tab to rotate between applications similarly to Alt-Tab on a Windows machine. However, when the Screen Sharing application has focus, the Command-Tab is being interpreted by the target screen instead of my local Macintosh.

How can I override this behavior and have my Macintosh see the Command-Tab instead of the remote screen?

  • 2
    Good question. According to here, the hidden preference com.apple.ScreenSharing DoNotSendSystemKeys is ignored as of OS X Lion. – Daniel Beck Jul 28 '12 at 15:27
  • Unfortunately, as stated on that page, this no longer works in OS X 10.7 anymore. – WilliamKF Jul 28 '12 at 15:47
  • Try to change the mode to Full Screen. – kenorb Aug 14 '12 at 9:51
  • are you connecting from Mac to Mac? Which Screen Sharing application do you use? – kenorb Aug 14 '12 at 9:51
  • I'm connecting from a Mac to a Linux box. The Mac has an application called Screen Sharing that I am using. – WilliamKF Aug 14 '12 at 11:22
0

Realize this is old but I have found that killing the 'RFBEventHelperd' process using the Activity Monitor app allows Command-Tab to work properly with Screen Sharing. I have not seen any side effects in killing this process.

Only issue is that you have to kill this process every time you launch a new instance of Screen Sharing.

Here is the link where I found this solution: http://hints.macworld.com/article.php?story=20120221065822722

6

If you press optioncommandx, then the screen sharing window will go into 'observe mode', and won't accept any mouse or keyboard input. Then you can press commandtab and switch apps. I know this doesn't really fix your problem, but it's at least a quick workaround...

  • 1
    I actually have the opposite problem; I want cmd-tab to be captured by the remote host. Your solution works perfectly for this case. option-cmd-tab moves between remote apps! Thanks for the tip. – Blisterpeanuts Jun 21 '18 at 12:22
0

I think I have the solution. I've had the same problem. On both Macs go in the System Preferences to share screen options and be sure that "external management" or "remote management" is off and screenshare is on. Maybe I don't use exactly the right words, because I translated these from Dutch. I hope this helps you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.